aboutsummaryrefslogtreecommitdiffstats
path: root/main/lame
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-08-16 15:04:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-17 11:58:45 +0000
commitcef73e52aaf3445fa8fb5ca05f6d56a1f895f6ef (patch)
tree2f1bdea3f00d1058f66ef7f1107b61e92dca4537 /main/lame
parent4a22bad3310a37ebafbb7939343d39b5af85fad8 (diff)
downloadaports-cef73e52aaf3445fa8fb5ca05f6d56a1f895f6ef.tar.bz2
aports-cef73e52aaf3445fa8fb5ca05f6d56a1f895f6ef.tar.xz
main/lame: build fix for automake-1.12
Diffstat (limited to 'main/lame')
-rw-r--r--main/lame/APKBUILD11
-rw-r--r--main/lame/lame-automake-1.12.patch42
2 files changed, 51 insertions, 2 deletions
diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
index 0b4d4e5b45..3708772097 100644
--- a/main/lame/APKBUILD
+++ b/main/lame/APKBUILD
@@ -10,12 +10,18 @@ license="LGPL2+"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="nasm ncurses-dev autoconf automake libtool"
-source="http://downloads.sourceforge.net/project/lame/lame/$_ver/lame-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/project/lame/lame/$_ver/lame-$pkgver.tar.gz
+ lame-automake-1.12.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
# link fronted shared
sed -i -e 's/\(^LDFLAGS.*\)-static/\1/g' frontend/Makefile.am
@@ -53,4 +59,5 @@ package() {
fi
}
-md5sums="84835b313d4a8b68f5349816d33e07ce lame-3.99.5.tar.gz"
+md5sums="84835b313d4a8b68f5349816d33e07ce lame-3.99.5.tar.gz
+54814745b84480da3b643582f2e5b485 lame-automake-1.12.patch"
diff --git a/main/lame/lame-automake-1.12.patch b/main/lame/lame-automake-1.12.patch
new file mode 100644
index 0000000000..ef566ec841
--- /dev/null
+++ b/main/lame/lame-automake-1.12.patch
@@ -0,0 +1,42 @@
+--- ./configure.in.orig
++++ ./configure.in
+@@ -77,9 +77,6 @@
+ AC_MSG_RESULT(${GCC_version})
+ fi
+
+-dnl more automake stuff
+-AM_C_PROTOTYPES
+-
+ AC_CHECK_HEADER(dmalloc.h)
+ if test "${ac_cv_header_dmalloc_h}" = "yes"; then
+ AM_WITH_DMALLOC
+--- ./doc/html/Makefile.am.orig
++++ ./doc/html/Makefile.am
+@@ -1,7 +1,5 @@
+ ## $Id: Makefile.am,v 1.7 2010/09/30 20:58:40 jaz001 Exp $
+
+-AUTOMAKE_OPTIONS = foreign ansi2knr
+-
+ docdir = $(datadir)/doc
+ pkgdocdir = $(docdir)/$(PACKAGE)
+ htmldir = $(docdir)/html
+--- ./doc/man/Makefile.am.orig
++++ ./doc/man/Makefile.am
+@@ -1,7 +1,5 @@
+ ## $Id: Makefile.am,v 1.1 2000/10/22 11:39:44 aleidinger Exp $
+
+-AUTOMAKE_OPTIONS = foreign ansi2knr
+-
+ man_MANS = lame.1
+ EXTRA_DIST = ${man_MANS}
+
+--- ./libmp3lame/i386/Makefile.am.orig
++++ ./libmp3lame/i386/Makefile.am
+@@ -1,7 +1,5 @@
+ ## $Id: Makefile.am,v 1.26 2011/04/04 09:42:34 aleidinger Exp $
+
+-AUTOMAKE_OPTIONS = foreign $(top_srcdir)/ansi2knr
+-
+ DEFS = @DEFS@ @CONFIG_DEFS@
+
+ ECHO ?= echo