aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-31 18:52:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-01 08:42:42 +0000
commit82dbe3073835e085953461309fb5f2075327f1bd (patch)
tree3f97265fc801dc0eac853c38f1e9ef2b223834af /main/ldb
parentcde3f83b5048d82e2f490aedd28e34bddc7f32bd (diff)
downloadaports-82dbe3073835e085953461309fb5f2075327f1bd.tar.bz2
aports-82dbe3073835e085953461309fb5f2075327f1bd.tar.xz
main/ldb: moved from testing
Diffstat (limited to 'main/ldb')
-rw-r--r--main/ldb/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
new file mode 100644
index 0000000000..8d7cf29f48
--- /dev/null
+++ b/main/ldb/APKBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ldb
+pkgver=1.1.16
+pkgrel=0
+pkgdesc="A schema-less, ldap like, API and database"
+url="http://ldb.samba.org/"
+arch="all"
+license="LGPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev tevent-dev tdb-dev talloc-dev python-dev popt-dev"
+install=""
+subpackages="$pkgname-dev py-$pkgname:_py $pkgname-tools"
+source="http://samba.org/ftp/ldb/ldb-$pkgver.tar.gz"
+
+_builddir="$srcdir"/ldb-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-rpath \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --with-modulesdir=/usr/lib/ldb/modules \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+_py() {
+ pkgdesc="Python binding for the ldb library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libpyldb*.so.* "$subpkgdir"/usr/lib/
+}
+
+tools() {
+ pkgdesc="Tools to manage LDB files"
+ mkdir -p "$subpkgdir"/usr/lib/ldb
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/ || return 1
+ mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
+}
+
+md5sums="60865c0b5704469ee2e59703087c8ec8 ldb-1.1.16.tar.gz"
+sha256sums="15c679fc4f1ae5956f5f81bc7caf5840992db65da6c804854a893d1f6423daf9 ldb-1.1.16.tar.gz"
+sha512sums="dc0803e46dd8dfdbbe2c7e287ab97a54c38598a091b5aee55924f10cbf443ab44eb79295f50c373d28a037a442473375eee0d56ab9ee629d0ee2c66d0ba185d8 ldb-1.1.16.tar.gz"