aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:16:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:16:15 +0000
commit8db768693adb0c03dba1ce5b1b4e1b48144df011 (patch)
treef5522542a3ab300ee765f70f95a9e5c79aa2f03f /main/ldb
parent154d0de0751c7e77ae7099454b4a2693ad7f505d (diff)
downloadaports-8db768693adb0c03dba1ce5b1b4e1b48144df011.tar.bz2
aports-8db768693adb0c03dba1ce5b1b4e1b48144df011.tar.xz
main/ldb: fix musl build
Diffstat (limited to 'main/ldb')
-rw-r--r--main/ldb/APKBUILD14
-rw-r--r--main/ldb/fix-libreplace.patch84
2 files changed, 93 insertions, 5 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index 8d7cf29f48..86329f72db 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
pkgver=1.1.16
-pkgrel=0
+pkgrel=1
pkgdesc="A schema-less, ldap like, API and database"
url="http://ldb.samba.org/"
arch="all"
@@ -11,7 +11,8 @@ depends_dev=""
makedepends="$depends_dev tevent-dev tdb-dev talloc-dev python-dev popt-dev"
install=""
subpackages="$pkgname-dev py-$pkgname:_py $pkgname-tools"
-source="http://samba.org/ftp/ldb/ldb-$pkgver.tar.gz"
+source="http://samba.org/ftp/ldb/ldb-$pkgver.tar.gz
+ fix-libreplace.patch"
_builddir="$srcdir"/ldb-$pkgver
prepare() {
@@ -62,6 +63,9 @@ tools() {
mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
}
-md5sums="60865c0b5704469ee2e59703087c8ec8 ldb-1.1.16.tar.gz"
-sha256sums="15c679fc4f1ae5956f5f81bc7caf5840992db65da6c804854a893d1f6423daf9 ldb-1.1.16.tar.gz"
-sha512sums="dc0803e46dd8dfdbbe2c7e287ab97a54c38598a091b5aee55924f10cbf443ab44eb79295f50c373d28a037a442473375eee0d56ab9ee629d0ee2c66d0ba185d8 ldb-1.1.16.tar.gz"
+md5sums="60865c0b5704469ee2e59703087c8ec8 ldb-1.1.16.tar.gz
+b8c06c1a37bce8a7feea3b6896483da0 fix-libreplace.patch"
+sha256sums="15c679fc4f1ae5956f5f81bc7caf5840992db65da6c804854a893d1f6423daf9 ldb-1.1.16.tar.gz
+13617f691c648b44867c1a76d8be7c185021e8a8f3b695f8689a9f6244e65827 fix-libreplace.patch"
+sha512sums="dc0803e46dd8dfdbbe2c7e287ab97a54c38598a091b5aee55924f10cbf443ab44eb79295f50c373d28a037a442473375eee0d56ab9ee629d0ee2c66d0ba185d8 ldb-1.1.16.tar.gz
+4adbbeb75de6c55199e10f284e741ee252f403b7809251caf4baf378669770be01d469b23e12f8119ed5dca5080dd45bda1b5b78cc7a791be44c1eb6fb8c0fa2 fix-libreplace.patch"
diff --git a/main/ldb/fix-libreplace.patch b/main/ldb/fix-libreplace.patch
new file mode 100644
index 0000000000..cfe24757ec
--- /dev/null
+++ b/main/ldb/fix-libreplace.patch
@@ -0,0 +1,84 @@
+--- talloc-2.1.0.orig/lib/replace/replace.c
++++ talloc-2.1.0/lib/replace/replace.c
+@@ -508,28 +508,6 @@
+ # error "You need a strtoll function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOQ
+-long long int rep_strtoll(const char *str, char **endptr, int base)
+-{
+- long long int nb = strtoq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtoq function"
+-#endif /* HAVE_STRTOQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOLL */
+
+
+@@ -546,28 +524,6 @@
+ # error "You need a strtoull function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOUQ
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
+-{
+- unsigned long long int nb = strtouq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtouq function"
+-#endif /* HAVE_STRTOUQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOULL */
+
+ #ifndef HAVE_SETENV
+--- talloc-2.1.0.orig/lib/replace/replace.h
++++ talloc-2.1.0/lib/replace/replace.h
+@@ -355,21 +355,11 @@
+ #ifndef HAVE_STRTOLL
+ #define strtoll rep_strtoll
+ long long int rep_strtoll(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#define strtoll rep_strtoll
+-long long int rep_strtoll(const char *str, char **endptr, int base);
+ #endif
+-#endif
+
+ #ifndef HAVE_STRTOULL
+ #define strtoull rep_strtoull
+ unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
+-#define strtoull rep_strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#endif
+ #endif
+
+ #ifndef HAVE_FTRUNCATE