aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-18 14:13:36 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-19 13:04:10 +0000
commitf365da074680c8379d44e58bd2ab054bb359fde0 (patch)
tree30a7024105e164509b0c183da9a463577f2580fc /main/ldb
parentf00327d821431ec64ba14509cb72f85d0fa3c6a3 (diff)
downloadaports-f365da074680c8379d44e58bd2ab054bb359fde0.tar.bz2
aports-f365da074680c8379d44e58bd2ab054bb359fde0.tar.xz
main/ldb: upgrade to 1.1.31
Diffstat (limited to 'main/ldb')
-rw-r--r--main/ldb/APKBUILD38
1 files changed, 11 insertions, 27 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index 48b60be9bf..591e2cbca4 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,33 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
-pkgver=1.1.29
+pkgver=1.1.31
pkgrel=0
pkgdesc="A schema-less, ldap like, API and database"
url="http://ldb.samba.org/"
arch="all"
license="LGPLv3+"
-depends=""
-depends_dev=""
makedepends="$depends_dev tevent-dev py-tevent tdb-dev py-tdb talloc-dev
- python2-dev popt-dev"
-install=""
+ python2-dev popt-dev cmocka-dev"
subpackages="$pkgname-dev py-$pkgname:_py $pkgname-tools"
-source="http://samba.org/ftp/ldb/ldb-$pkgver.tar.gz
- "
+source="http://samba.org/ftp/ldb/ldb-$pkgver.tar.gz"
-_builddir="$srcdir"/ldb-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/ldb-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,14 +26,13 @@ build() {
--disable-rpath \
--bundled-libraries=NONE \
--builtin-libraries=replace \
- --with-modulesdir=/usr/lib/ldb/modules \
- || return 1
- make || return 1
+ --with-modulesdir=/usr/lib/ldb/modules
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
_py() {
@@ -59,10 +45,8 @@ _py() {
tools() {
pkgdesc="Tools to manage LDB files"
mkdir -p "$subpkgdir"/usr/lib/ldb
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/ || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
}
-md5sums="9c90abfb94c1e2a693399392cf4cddb9 ldb-1.1.29.tar.gz"
-sha256sums="59d84f9a5b799f519ba7b2685bb46f5a26f1bbf05b7a144b2f5e017d01d80f97 ldb-1.1.29.tar.gz"
-sha512sums="d37bbe84358e05d17483e2e963b8477da5ea351b855b454142c94af35f7987bede0f19faeaff17779efe04e3bb37c510437fcc59be99a17c826620fc25fd659c ldb-1.1.29.tar.gz"
+sha512sums="49ccd57000cbcc6d828160f4457236b28853d766d641841471f61226156b6103fe563c43c950577b038ea3c0a54506bca94c640d3d5f912a3b8af95eb9ef2824 ldb-1.1.31.tar.gz"