aboutsummaryrefslogtreecommitdiffstats
path: root/main/lftp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-17 08:29:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-17 08:29:04 +0000
commit0f9935dbde2ee3ecea57f79095c4d17afb39a77c (patch)
tree4a467df7151f29fb0cc63c4239a3b037095ef032 /main/lftp
parentd7ad83c5a4acb9916e03b6deb79f364e83108fff (diff)
downloadaports-0f9935dbde2ee3ecea57f79095c4d17afb39a77c.tar.bz2
aports-0f9935dbde2ee3ecea57f79095c4d17afb39a77c.tar.xz
main/lftp: properly fix musl build
The gnulib tests were ran in a wrong way. Filed issue upstream: https://github.com/lavv17/lftp/issues/59
Diffstat (limited to 'main/lftp')
-rw-r--r--main/lftp/0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch30
-rw-r--r--main/lftp/APKBUILD15
-rw-r--r--main/lftp/musl-fix.patch11
3 files changed, 39 insertions, 17 deletions
diff --git a/main/lftp/0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch b/main/lftp/0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
new file mode 100644
index 0000000000..2e7a93af3d
--- /dev/null
+++ b/main/lftp/0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
@@ -0,0 +1,30 @@
+From d78ec3f29eca74d17a01d717e10ef6fad1a85a15 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 17 Feb 2014 08:20:41 +0000
+Subject: [PATCH] run the gunlib checks with same compiler as when building
+
+The gnulib will be built with $CC and not $CXX so we should not run the
+gnulib tests with $CXX.
+
+This fixes lavv17/lftp#59
+---
+ configure.ac | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index faca8e5..5d52f1a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -237,9 +237,7 @@ fi
+ AM_PROG_LIBTOOL
+ LIBTOOL="$LIBTOOL --silent"
+
+-AC_LANG_PUSH(C++)
+ gl_INIT
+-AC_LANG_POP(C++)
+
+ if test x$ac_cv_func_wcwidth != xyes || test x$REPLACE_WCWIDTH = x1; then
+ gl_LIBOBJ([wcwidth])
+--
+1.8.5.4
+
diff --git a/main/lftp/APKBUILD b/main/lftp/APKBUILD
index 75dfd02856..c4d095f463 100644
--- a/main/lftp/APKBUILD
+++ b/main/lftp/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=lftp
pkgver=4.4.15
-pkgrel=1
+pkgrel=2
pkgdesc="LFTP is sophisticated ftp/http client"
url="http://lftp.yar.ru/"
arch="all"
license="GPL"
depends=
-makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev"
+makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev autoconf automake
+ libtool"
subpackages="$pkgname-doc"
source="http://lftp.yar.ru/ftp/lftp-$pkgver.tar.xz
- musl-fix.patch"
+ 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -23,6 +24,8 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --add-missing || return 1
}
build() {
@@ -53,8 +56,8 @@ package() {
}
md5sums="f19cc0cea1d427aa2a952b27661b91e5 lftp-4.4.15.tar.xz
-696ee578b149914ad230190fba6b83d6 musl-fix.patch"
+91de52bcbda9490d62cea72be78ab72a 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
sha256sums="75f40b7ab438a7b295410eb3e1ec8460e36ad2d48785383a6fc9201905db6868 lftp-4.4.15.tar.xz
-8b85bfa39de217d8fb765ee9b8f26b4368fd9002a40e5b75dee466c3a59024cd musl-fix.patch"
+e50ae5f0db272a31146cc29909bd07a1b7c11c78dad6e9a51eb3ad4231b5c323 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
sha512sums="1d828a7b2ff808a0ee78f51c265d58df677e67cec9b4744cbd3a34816aba324199202094fa4144665e8d64385df7e76a54c6dc415e9ff33e97adab2eb0edaf4e lftp-4.4.15.tar.xz
-e9fab08f570032ad6b006d05446d583441dc5a1c236343b8de89f31fad7df2f969cfe9f888c371acbf24c69b2c07e66d736105101739cc4753299feef7f372a4 musl-fix.patch"
+3f7e7958787c323b148415ba42d8748d27a515da2dbc62c087e778190806cf6f683900966c359829d3ba1a4d8d06a874d35c41316c89059b1c85806328f422cc 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
diff --git a/main/lftp/musl-fix.patch b/main/lftp/musl-fix.patch
deleted file mode 100644
index 8f09658ff3..0000000000
--- a/main/lftp/musl-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lftp-4.4.15/lib/stdbool.in.h.orig
-+++ lftp-4.4.15/lib/stdbool.in.h
-@@ -111,7 +111,7 @@
- (see ISO C 99 6.7.2.2.(4)); however, '_Bool' must promote to 'int'
- (see ISO C 99 6.3.1.1.(2)). So add a negative value to the
- enum; this ensures that '_Bool' promotes to 'int'. */
--typedef enum { _Bool_must_promote_to_int = -1, false = 0, true = 1 } _Bool;
-+typedef enum { _Bool_must_promote_to_int = -1, false = 0, true = 1 }; _Bool;
- # endif
- # endif
- # endif