aboutsummaryrefslogtreecommitdiffstats
path: root/main/lftp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-02-16 11:35:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-02-16 11:35:33 +0000
commite5384ed6d877f7de674cb3ee6db8972585a8e5cf (patch)
tree802ef8d7a014506c0b060007732aa27a135f2d82 /main/lftp
parent70f5b33b867f28eb2a65b723358fde8e075f5aa3 (diff)
downloadaports-e5384ed6d877f7de674cb3ee6db8972585a8e5cf.tar.bz2
aports-e5384ed6d877f7de674cb3ee6db8972585a8e5cf.tar.xz
main/lftp: fix musl build
Diffstat (limited to 'main/lftp')
-rw-r--r--main/lftp/APKBUILD33
-rw-r--r--main/lftp/musl-fix.patch11
2 files changed, 34 insertions, 10 deletions
diff --git a/main/lftp/APKBUILD b/main/lftp/APKBUILD
index b04063f1ce..75dfd02856 100644
--- a/main/lftp/APKBUILD
+++ b/main/lftp/APKBUILD
@@ -2,21 +2,27 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=lftp
pkgver=4.4.15
-pkgrel=0
+pkgrel=1
pkgdesc="LFTP is sophisticated ftp/http client"
url="http://lftp.yar.ru/"
arch="all"
license="GPL"
depends=
-makedepends="openssl-dev readline-dev ncurses-dev gettext-dev"
+makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev"
subpackages="$pkgname-doc"
-source="http://lftp.yar.ru/ftp/lftp-$pkgver.tar.xz"
+source="http://lftp.yar.ru/ftp/lftp-$pkgver.tar.xz
+ musl-fix.patch"
_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -29,9 +35,12 @@ build() {
--sysconfdir=/etc/lftp \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --with-gnutls \
--with-modules \
--disable-nls \
- --with-openssl \
+ --disable-static \
+ --with-gnutls \
+ --without-openssl \
|| return 1
make || return 1
}
@@ -39,9 +48,13 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/lib/*.la
+ rm -f "$pkgdir"/usr/lib/*.la
+ rm -f "$pkgdir"/usr/lib/charset.alias
}
-md5sums="f19cc0cea1d427aa2a952b27661b91e5 lftp-4.4.15.tar.xz"
-sha256sums="75f40b7ab438a7b295410eb3e1ec8460e36ad2d48785383a6fc9201905db6868 lftp-4.4.15.tar.xz"
-sha512sums="1d828a7b2ff808a0ee78f51c265d58df677e67cec9b4744cbd3a34816aba324199202094fa4144665e8d64385df7e76a54c6dc415e9ff33e97adab2eb0edaf4e lftp-4.4.15.tar.xz"
+md5sums="f19cc0cea1d427aa2a952b27661b91e5 lftp-4.4.15.tar.xz
+696ee578b149914ad230190fba6b83d6 musl-fix.patch"
+sha256sums="75f40b7ab438a7b295410eb3e1ec8460e36ad2d48785383a6fc9201905db6868 lftp-4.4.15.tar.xz
+8b85bfa39de217d8fb765ee9b8f26b4368fd9002a40e5b75dee466c3a59024cd musl-fix.patch"
+sha512sums="1d828a7b2ff808a0ee78f51c265d58df677e67cec9b4744cbd3a34816aba324199202094fa4144665e8d64385df7e76a54c6dc415e9ff33e97adab2eb0edaf4e lftp-4.4.15.tar.xz
+e9fab08f570032ad6b006d05446d583441dc5a1c236343b8de89f31fad7df2f969cfe9f888c371acbf24c69b2c07e66d736105101739cc4753299feef7f372a4 musl-fix.patch"
diff --git a/main/lftp/musl-fix.patch b/main/lftp/musl-fix.patch
new file mode 100644
index 0000000000..8f09658ff3
--- /dev/null
+++ b/main/lftp/musl-fix.patch
@@ -0,0 +1,11 @@
+--- lftp-4.4.15/lib/stdbool.in.h.orig
++++ lftp-4.4.15/lib/stdbool.in.h
+@@ -111,7 +111,7 @@
+ (see ISO C 99 6.7.2.2.(4)); however, '_Bool' must promote to 'int'
+ (see ISO C 99 6.3.1.1.(2)). So add a negative value to the
+ enum; this ensures that '_Bool' promotes to 'int'. */
+-typedef enum { _Bool_must_promote_to_int = -1, false = 0, true = 1 } _Bool;
++typedef enum { _Bool_must_promote_to_int = -1, false = 0, true = 1 }; _Bool;
+ # endif
+ # endif
+ # endif