aboutsummaryrefslogtreecommitdiffstats
path: root/main/libarchive
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-07-14 20:18:57 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-14 18:23:31 +0000
commit5ab4f01b1aff123187615c37e8c42f1b899e16b1 (patch)
tree2759c828d718b29406bb304aa08d7adf56f72e4f /main/libarchive
parentfe77543906ee4d5604f09f9033b07f710c8346da (diff)
downloadaports-5ab4f01b1aff123187615c37e8c42f1b899e16b1.tar.bz2
aports-5ab4f01b1aff123187615c37e8c42f1b899e16b1.tar.xz
main/libarchive: upgrade to 3.3.2
* Remove merged patch * Modernize abuild
Diffstat (limited to 'main/libarchive')
-rw-r--r--main/libarchive/APKBUILD18
-rw-r--r--main/libarchive/libressl.patch22
2 files changed, 7 insertions, 33 deletions
diff --git a/main/libarchive/APKBUILD b/main/libarchive/APKBUILD
index 122e8347a8..5e17cde19d 100644
--- a/main/libarchive/APKBUILD
+++ b/main/libarchive/APKBUILD
@@ -1,17 +1,15 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libarchive
-pkgver=3.3.1
-pkgrel=1
+pkgver=3.3.2
+pkgrel=0
pkgdesc="library that can create and read several streaming archive formats"
url="http://libarchive.org/"
arch="all"
license="BSD"
makedepends="zlib-dev bzip2-dev xz-dev lz4-dev acl-dev libressl-dev expat-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="http://www.libarchive.org/downloads/$pkgname-$pkgver.tar.gz
- libressl.patch
- "
+source="http://www.libarchive.org/downloads/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build () {
@@ -20,14 +18,13 @@ build () {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --without-xml2 \
- || return 1
- make || return 1
+ --without-xml2
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
tools() {
@@ -37,5 +34,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="90702b393b6f0943f42438e277b257af45eee4fa82420431f6a4f5f48bb846f2a72c8ff084dc3ee9c87bdf8b57f4d8dddf7814870fe2604fe86c55d8d744c164 libarchive-3.3.1.tar.gz
-749cd7ef6ed9e12b3ac1f2ffc302e3d2fca0bf6634f77e7ae155ae1b51415744b908d6a014c1bbf1abc8d1eeee191781a21aebd4dd680dd21e6b96da7e0547f0 libressl.patch"
+sha512sums="1e538cd7d492f54b11c16c56f12c1632ba14302a3737ec0db786272aec0c8020f1e27616a7654d57e26737e5ed9bfc9a62f1fdda61a95c39eb726aa7c2f673e4 libarchive-3.3.2.tar.gz"
diff --git a/main/libarchive/libressl.patch b/main/libarchive/libressl.patch
deleted file mode 100644
index 05b7c1b4eb..0000000000
--- a/main/libarchive/libressl.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/libarchive/archive_openssl_hmac_private.h
-+++ b/libarchive/archive_openssl_hmac_private.h
-@@ -28,7 +28,7 @@
- #include <openssl/hmac.h>
- #include <openssl/opensslv.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline HMAC_CTX *HMAC_CTX_new(void)
---- a/libarchive/archive_openssl_evp_private.h
-+++ b/libarchive/archive_openssl_evp_private.h
-@@ -28,7 +28,7 @@
- #include <openssl/evp.h>
- #include <openssl/opensslv.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline EVP_MD_CTX *EVP_MD_CTX_new(void)