aboutsummaryrefslogtreecommitdiffstats
path: root/main/libasr
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-04 18:07:07 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-04 18:11:04 +0100
commitcac4506ff02b575c4dae4f780b6639e470bbca78 (patch)
tree81771a3253e57589ce253db398419359915db47d /main/libasr
parent16a9b0f6e18c36586c47bfdba1770ce7cacfbeb5 (diff)
downloadaports-cac4506ff02b575c4dae4f780b6639e470bbca78.tar.bz2
aports-cac4506ff02b575c4dae4f780b6639e470bbca78.tar.xz
main/libasr: upgrade to 1.0.3
Diffstat (limited to 'main/libasr')
-rw-r--r--main/libasr/0001-Fix-NETDB_SUCCESS-value.patch25
-rw-r--r--main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch26
-rw-r--r--main/libasr/0003-no-need-for-openssl-in-libasr.patch25
-rw-r--r--main/libasr/0004-mod_automake_bootstrap_version.patch11
-rw-r--r--main/libasr/APKBUILD28
5 files changed, 24 insertions, 91 deletions
diff --git a/main/libasr/0001-Fix-NETDB_SUCCESS-value.patch b/main/libasr/0001-Fix-NETDB_SUCCESS-value.patch
deleted file mode 100644
index 34ae1807b0..0000000000
--- a/main/libasr/0001-Fix-NETDB_SUCCESS-value.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 37b6c29ad32692aa0fea5a65492ddbea0b4a8b5d Mon Sep 17 00:00:00 2001
-From: Jonathan Curran <jonathan@curran.in>
-Date: Wed, 9 Sep 2015 17:11:55 +0000
-Subject: [PATCH 1/3] Fix NETDB_SUCCESS value
-
----
- openbsd-compat/defines.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/openbsd-compat/defines.h b/openbsd-compat/defines.h
-index da7a42c..9f50ece 100644
---- a/openbsd-compat/defines.h
-+++ b/openbsd-compat/defines.h
-@@ -823,7 +823,7 @@ struct winsize {
- #endif
-
- #ifndef NETDB_SUCCESS
--# define NETDB_SUCCESS -1
-+# define NETDB_SUCCESS 0
- #endif
-
- /* end of chl */
---
-2.11.1
-
diff --git a/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch b/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
index 7383976d20..a843125a5a 100644
--- a/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
+++ b/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
@@ -15,26 +15,25 @@ diff --git a/configure.ac b/configure.ac
index 10aff04..fa0e896 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -264,6 +264,8 @@ AC_ARG_WITH([Werror],
- )
- #l325
+@@ -87,6 +87,8 @@
+ # libasr specific checks.
+ #
+LIBS="-lcrypto -lbsd $LIBS"
+
- AC_CHECK_HEADERS([ \
- crypt.h \
- dirent.h \
+ # This ought to be part of the generic compat library, but we don't want to force
+ # linking against other libs (-lresolv for instance) in all cases.
+ # It has to be improved at some point.
diff --git a/openbsd-compat/openbsd-compat.h b/openbsd-compat/openbsd-compat.h
index c30591c..9be2e0b 100644
---- a/openbsd-compat/openbsd-compat.h
-+++ b/openbsd-compat/openbsd-compat.h
-@@ -123,4 +123,6 @@ int res_hnok(const char *);
- int clock_gettime(int, struct timespec *);
+--- a/openbsd-compat/includes/compat-stdlib.h
++++ b/openbsd-compat/includes/compat-stdlib.h
+@@ -30,3 +30,5 @@
+ long long strtonum(const char *nptr, long long minval, long long maxval,
+ const char **errstr);
#endif
-
-+unsigned int arc4random(void);
+
- #endif /* _OPENBSD_COMPAT_H */
++unsigned int arc4random(void);
diff --git a/src/res_mkquery.c b/src/res_mkquery.c
index 27ed21e..cce4029 100644
--- a/src/res_mkquery.c
@@ -63,4 +62,3 @@ index a60aa0d..a0f4704 100644
h.qdcount = 1;
--
2.11.1
-
diff --git a/main/libasr/0003-no-need-for-openssl-in-libasr.patch b/main/libasr/0003-no-need-for-openssl-in-libasr.patch
deleted file mode 100644
index 1e91c66003..0000000000
--- a/main/libasr/0003-no-need-for-openssl-in-libasr.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a392a940bd0c83393fd76eabe08b1743b396b095 Mon Sep 17 00:00:00 2001
-From: Gilles Chehade <gilles@poolp.org>
-Date: Sat, 13 Feb 2016 14:03:02 +0100
-Subject: [PATCH 3/3] no need for openssl in libasr...
-
----
- openbsd-compat/includes.h | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/openbsd-compat/includes.h b/openbsd-compat/includes.h
-index bc3d46b..5b680d3 100644
---- a/openbsd-compat/includes.h
-+++ b/openbsd-compat/includes.h
-@@ -70,8 +70,6 @@
- #endif
- /* end of chl*/
-
--#include <openssl/opensslv.h> /* For OPENSSL_VERSION_NUMBER */
--
- #include "defines.h"
-
- #include "openbsd-compat.h"
---
-2.11.1
-
diff --git a/main/libasr/0004-mod_automake_bootstrap_version.patch b/main/libasr/0004-mod_automake_bootstrap_version.patch
deleted file mode 100644
index cd41f89c62..0000000000
--- a/main/libasr/0004-mod_automake_bootstrap_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bootstrap
-+++ b/bootstrap
-@@ -36,7 +36,7 @@
-
- # Check for automake
- amvers="no"
--for v in 15 14 13 12 11 10 9 8 7 6 5; do
-+for v in 16 15 14 13 12 11 10 9 8 7 6 5; do
- if automake-1.${v} --version >/dev/null 2>&1; then
- amvers="-1.${v}"
- break
diff --git a/main/libasr/APKBUILD b/main/libasr/APKBUILD
index 959af9e5e5..4340080b0d 100644
--- a/main/libasr/APKBUILD
+++ b/main/libasr/APKBUILD
@@ -1,31 +1,30 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libasr
-pkgver=1.0.2
-pkgrel=9
+pkgver=1.0.3
+pkgrel=0
pkgdesc="libasr is a free, simple and portable asynchronous resolver library"
url="https://www.opensmtpd.org"
arch="all"
license="ISC"
-options="!check"
makedepends="mdocml bison openssl-dev automake autoconf libtool libbsd-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/OpenSMTPD/libasr/archive/libasr-$pkgver.tar.gz
- 0001-Fix-NETDB_SUCCESS-value.patch
+subpackages="$pkgname-static $pkgname-dev"
+source="https://github.com/OpenSMTPD/libasr/archive/$pkgver/$pkgname-$pkgver.tar.gz
0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
- 0003-no-need-for-openssl-in-libasr.patch
- 0004-mod_automake_bootstrap_version.patch
"
-builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
./bootstrap
}
+check() {
+ gcc -L src/.libs -I src tests/asr_simple.c -lasr -o tests/asr_simple
+ LD_LIBRARY_PATH=src/.libs ./tests/asr_simple
+}
+
build() {
- # XXX: Hotfix, see: https://github.com/OpenSMTPD/libasr/pull/18
- CFLAGS="-Wno-error=maybe-uninitialized" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,8 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="d70d5fb5728678074f4fd3d0f925b13a8a5ac9fec7a38277f2ed0e6b3f3fe2591845d035f43ece1ee16f1fdfd7d7443140ca36f171f94f310ed821b88b82b924 libasr-1.0.2.tar.gz
-aebd80ae1fd33604f547833d4244161cc8551404c61e666967062e484a30d88f597e71c9f9956a3604bf02e625d8aabd9b4669d3efad1a2a15efb2f8acd8ac03 0001-Fix-NETDB_SUCCESS-value.patch
-1f189036d9f2cc0b7442412cf6349f5a1e567d23a05641c397ee4f5c6ac13a690afd4f5586cb645291682408664dc7582a9ca7552f7ddb6c1aca16bf49c313ef 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
-32ffc6e64d9eeb7aa37a2f4b4633ac462508f2ee7a9152b6c6b87aeebdcc89e809e839d4cc66ed49486b98d34706ff8cd86d8466663bd8712dacd99cfec64e03 0003-no-need-for-openssl-in-libasr.patch
-1dca9d2f46c0d34af636469fcd3a8e6febadbbd8a39ba496562cdf17f444ea00c8f247ae6e37dda87bb841b7ecf771164968bdd78a0bd4c69b00e060b4426bb3 0004-mod_automake_bootstrap_version.patch"
+sha512sums="51b21a0494f154514d702b4e1076dd25554f98606e166f1c9f7dde5f33d84fce5d82fd14e930aeacab8e1624a13d720e4c997184d47b5964cfab717f4d18dc03 libasr-1.0.3.tar.gz
+693c2bfce2ca9397909a281b3d634b37608ff6286a4e9b3c1d638a337c585d307db4a325fb8b607ef45399c1ee05063eda5eb46060d804e5b4ad51ca6890846d 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch"