aboutsummaryrefslogtreecommitdiffstats
path: root/main/libavc1394
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-25 10:51:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-25 10:51:06 +0000
commitfdaeaeae0c3e0baacbcd010f170e47ca4bc0881a (patch)
treeb8ca2e9fae75831cc5da75f1654f09a4a161bf68 /main/libavc1394
parent9a693067ee9cf55ae097b40fce9101d7e003a81a (diff)
downloadaports-fdaeaeae0c3e0baacbcd010f170e47ca4bc0881a.tar.bz2
aports-fdaeaeae0c3e0baacbcd010f170e47ca4bc0881a.tar.xz
main/libavc1394: upgrade to 0.5.4
Diffstat (limited to 'main/libavc1394')
-rw-r--r--main/libavc1394/APKBUILD13
-rw-r--r--main/libavc1394/argp.patch11
2 files changed, 19 insertions, 5 deletions
diff --git a/main/libavc1394/APKBUILD b/main/libavc1394/APKBUILD
index 9310215de2..e43a33356b 100644
--- a/main/libavc1394/APKBUILD
+++ b/main/libavc1394/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libavc1394
-pkgver=0.5.3
-pkgrel=1
+pkgver=0.5.4
+pkgrel=0
pkgdesc="Audio/Video Control library for IEEE-1394 devices"
url="http://sourceforge.net/projects/libavc1394/"
arch="all"
license="GPLv2+ LGPLv2+"
depends=
depends_dev="libraw1394-dev"
-makedepends="$depends_dev"
+makedepends="$depends_dev libtool automake autoconf argp-standalone"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz
+ argp.patch"
_builddir="$srcdir"/libavc1394-$pkgver
prepare() {
@@ -23,6 +24,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ libtoolize && aclocal && autoconf && automake
}
build() {
@@ -42,4 +44,5 @@ package() {
rm "$pkgdir"/usr/lib/*.la
}
-md5sums="09e30b1fb5ae455b6d8407e457a711a3 libavc1394-0.5.3.tar.gz"
+md5sums="caf0db059d8b8d35d6f08e6c0e1c7dfe libavc1394-0.5.4.tar.gz
+c939fbdf47f9e5cd5511cd23acb6e835 argp.patch"
diff --git a/main/libavc1394/argp.patch b/main/libavc1394/argp.patch
new file mode 100644
index 0000000000..9c86a625e5
--- /dev/null
+++ b/main/libavc1394/argp.patch
@@ -0,0 +1,11 @@
+--- ./configure.in.orig
++++ ./configure.in
+@@ -11,6 +11,8 @@
+
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(sys/time.h sys/types.h unistd.h string.h netinet/in.h stdio.h)
++AC_SEARCH_LIBS([argp_usage], [argp], [],
++ [AC_MSG_ERROR([argp not found. Consider installing argp-standalone])])
+ PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0)
+
+ #set the libtool shared library version numbers