aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-03 15:19:07 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-03 19:49:24 +0000
commitc75c9f42185a529d12cf4c5a802aad26f34fa5b7 (patch)
tree7cba163889807acbee845a4a8b98975764918cce /main/libbsd
parent5f01e131308327cf13857bcfdf33b94ed19e8faa (diff)
downloadaports-c75c9f42185a529d12cf4c5a802aad26f34fa5b7.tar.bz2
aports-c75c9f42185a529d12cf4c5a802aad26f34fa5b7.tar.xz
libbsd: adopt; upgrade to 0.9.1
Diffstat (limited to 'main/libbsd')
-rw-r--r--main/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch5
-rw-r--r--main/libbsd/APKBUILD15
-rw-r--r--main/libbsd/headers.patch10
3 files changed, 21 insertions, 9 deletions
diff --git a/main/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch b/main/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
index e97e30e846..0d4007d09d 100644
--- a/main/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+++ b/main/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
@@ -205,7 +205,7 @@ diff --git a/include/bsd/string.h b/include/bsd/string.h
index ee2f953..fbf8c54 100644
--- a/include/bsd/string.h
+++ b/include/bsd/string.h
-@@ -36,13 +36,19 @@
+@@ -36,16 +36,22 @@
#include <sys/cdefs.h>
#include <sys/types.h>
@@ -219,7 +219,10 @@ index ee2f953..fbf8c54 100644
char *strnstr(const char *str, const char *find, size_t str_len);
void strmode(mode_t mode, char *str);
+ #if !defined(__GLIBC__) || \
+ (defined(__GLIBC__) && (!__GLIBC_PREREQ(2, 25) || !defined(_GNU_SOURCE)))
void explicit_bzero(void *buf, size_t len);
+ #endif
-__END_DECLS
+#ifdef __cplusplus
+}
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index 36b87316ef..4fa127bf28 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor:
-# Maintainer:
+# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=libbsd
-pkgver=0.8.6
-pkgrel=2
+pkgver=0.9.1
+pkgrel=0
pkgdesc="commonly-used BSD functions not implemented by all libcs"
url="https://libbsd.freedesktop.org/"
arch="all"
@@ -14,8 +13,8 @@ makedepends_build="autoconf automake libtool"
makedepends_host="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
- 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
disable-fpurge-test.patch
+ headers.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -49,6 +48,6 @@ package() {
install
}
-sha512sums="ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b libbsd-0.8.6.tar.xz
-4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
-34ab57a9b67c0d6035312dff78e6dd0d1c48442c6a1b6e769b6ebb6dccb0dac80ccc2c309724e39c097cdac944bdbd9522582f93f2567da8c6615990e2d0238b disable-fpurge-test.patch"
+sha512sums="435822b8f2495a5e2705e5ab5c834a4f0f3a177b3e5c46a7c6162924507ca984e957e94a512b5ebd0067ecb413bac458fade357709ef199e9b75edf0315de91c libbsd-0.9.1.tar.xz
+34ab57a9b67c0d6035312dff78e6dd0d1c48442c6a1b6e769b6ebb6dccb0dac80ccc2c309724e39c097cdac944bdbd9522582f93f2567da8c6615990e2d0238b disable-fpurge-test.patch
+594d598bc7f6d34bff080a26f8d726bf779d3827423f242ee7caa9a58fc89c89d80e0677c03e9c640e0074afbdc34636fa8ffa47a99fd9c576845e3039a7ccbd headers.patch"
diff --git a/main/libbsd/headers.patch b/main/libbsd/headers.patch
new file mode 100644
index 0000000000..5b8f264253
--- /dev/null
+++ b/main/libbsd/headers.patch
@@ -0,0 +1,10 @@
+--- libbsd-0.9.1/src/flopen.c.old 2018-05-21 02:33:33.000000000 +0000
++++ libbsd-0.9.1/src/flopen.c 2018-09-09 17:43:59.850000000 +0000
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+
+ #include <errno.h>
++#include <fcntl.h>
+ #include <stdarg.h>
+ #include <unistd.h>
+