aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc-dev
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-11-22 22:44:31 +0100
committerTimo Teräs <timo.teras@iki.fi>2016-12-26 10:00:31 +0000
commit8db10f90bc1848cd8050dfe0df9cc40671225d39 (patch)
tree03b3d87ff2ed61d7d76cf8f3f63809c58516ba70 /main/libc-dev
parente5af917464c22e4b641b125399b11c996cdf9aa8 (diff)
downloadaports-8db10f90bc1848cd8050dfe0df9cc40671225d39.tar.bz2
aports-8db10f90bc1848cd8050dfe0df9cc40671225d39.tar.xz
main/libc-dev: Update sys/queue.h from NetBSD sources and bump ver.
Apply recent changes done by Christos Zoulas <christos@zoulas.com>. http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/src/sys/sys/queue.h?rev=1.70 * Revision 1.69, Mon Nov 2 14:49:07 2015 UTC by christos: Use existing macros to implement TAILQ_FOREACH_REVERSE, like TAILQ_FOREACH_REVERSE_SAFE does. * Revision 1.70, Mon Nov 2 15:21:23 2015 UTC by christos: Add missing paren.
Diffstat (limited to 'main/libc-dev')
-rw-r--r--main/libc-dev/APKBUILD10
-rw-r--r--main/libc-dev/sys-queue.h10
2 files changed, 10 insertions, 10 deletions
diff --git a/main/libc-dev/APKBUILD b/main/libc-dev/APKBUILD
index 849bd71bfe..f639589560 100644
--- a/main/libc-dev/APKBUILD
+++ b/main/libc-dev/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libc-dev
-pkgver=0.7
-pkgrel=1
+pkgver=0.7.1
+pkgrel=0
pkgdesc="Meta package to pull in correct libc"
url="http://alpinelinux.org"
arch="noarch"
@@ -53,11 +53,11 @@ bsdcompat() {
}
md5sums="5b125c4b64aef6d89766f657709cf0e4 sys-cdefs.h
-c2784afaed83839546ba733e8a0435c7 sys-queue.h
+9a3f0035d89763e26ceee03235fd5d93 sys-queue.h
8d0bcd3f4b10dfc5c74d5bb4c0d6722b sys-tree.h"
sha256sums="30bb6d7e0e0b61fcd95d830c376c829a614bce4683c1b97e06c201ec2c6e839a sys-cdefs.h
-3659cd137c320991a78413dd370a92fd18e0a8bc36d017d554f08677a37d7d5a sys-queue.h
+c13407edd0e33be73cae72514cb234f8612e1c0e54401c9448daffd3a240158b sys-queue.h
e1e498a79bf160a5766fa560f2b07b206fe89fe21a62600c77d72e00a6992f92 sys-tree.h"
sha512sums="8c3fddd73b696a38e633953715c79c47703739be27ee085fc6c960a57b6746ca05bf6406f7e6126cc1a13204254fd5830afb566624e1f298f4d6b58216013c28 sys-cdefs.h
-19cec4d39310285eb49ad1beae86884080e0152f9477757513050211b31f95ee7283a64ae95939683df09231cfb021ace816b26981ad05f4fff0a39519f935fe sys-queue.h
+2f0d5e6e4dc3350285cf17009265dddcbe12431c111868eea39bc8cb038ab7c1f2acacbb21735c4e9d4a1fd106a8fc0f8611ea33987d4faba37dde5ce6da0750 sys-queue.h
07cb70f2f0ddb31e23dd913c6f561fc9885667c5803fdf3a559676c99d08834b4104589bacb5d17b4a0b379c68c81a1cf3173832b3da33a7b936fa7b93706844 sys-tree.h"
diff --git a/main/libc-dev/sys-queue.h b/main/libc-dev/sys-queue.h
index 99d01a55b1..a38499a267 100644
--- a/main/libc-dev/sys-queue.h
+++ b/main/libc-dev/sys-queue.h
@@ -1,4 +1,4 @@
-/* $NetBSD: queue.h,v 1.68 2014/11/19 08:10:01 uebayasi Exp $ */
+/* $NetBSD: queue.h,v 1.70 2015/11/02 15:21:23 christos Exp $ */
/*
* Copyright (c) 1991, 1993
@@ -421,9 +421,9 @@ struct { \
#define TAILQ_END(head) (NULL)
#define TAILQ_NEXT(elm, field) ((elm)->field.tqe_next)
#define TAILQ_LAST(head, headname) \
- (*(((struct headname *)((head)->tqh_last))->tqh_last))
+ (*(((struct headname *)(void *)((head)->tqh_last))->tqh_last))
#define TAILQ_PREV(elm, headname, field) \
- (*(((struct headname *)((elm)->field.tqe_prev))->tqh_last))
+ (*(((struct headname *)(void *)((elm)->field.tqe_prev))->tqh_last))
#define TAILQ_EMPTY(head) (TAILQ_FIRST(head) == TAILQ_END(head))
@@ -438,9 +438,9 @@ struct { \
((next) = TAILQ_NEXT(var, field), 1); (var) = (next))
#define TAILQ_FOREACH_REVERSE(var, head, headname, field) \
- for ((var) = (*(((struct headname *)((head)->tqh_last))->tqh_last));\
+ for ((var) = TAILQ_LAST((head), headname); \
(var) != TAILQ_END(head); \
- (var) = (*(((struct headname *)((var)->field.tqe_prev))->tqh_last)))
+ (var) = TAILQ_PREV((var), headname, field))
#define TAILQ_FOREACH_REVERSE_SAFE(var, head, headname, field, prev) \
for ((var) = TAILQ_LAST((head), headname); \