aboutsummaryrefslogtreecommitdiffstats
path: root/main/libcddb
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 21:52:55 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:18:46 +0000
commitdbda201ce26614edfe370a6e248febdd61520425 (patch)
tree962802da7541045180000945be6b7c46cac07c1d /main/libcddb
parente2bbdf65e003295ed769605b6d28c51ca80581f2 (diff)
downloadaports-dbda201ce26614edfe370a6e248febdd61520425.tar.bz2
aports-dbda201ce26614edfe370a6e248febdd61520425.tar.xz
main/libcddb: modernise, fix license, broken tests
Diffstat (limited to 'main/libcddb')
-rw-r--r--main/libcddb/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/main/libcddb/APKBUILD b/main/libcddb/APKBUILD
index 7c67c01f58..c37a507aef 100644
--- a/main/libcddb/APKBUILD
+++ b/main/libcddb/APKBUILD
@@ -2,40 +2,39 @@
# Maintainer:
pkgname=libcddb
pkgver=1.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="Library that implements the different protocols (CDDBP, HTTP, SMTP) to access data on a CDDB server (e.g. http://freedb.org)."
url="https://sourceforge.net/projects/libcddb/"
arch="all"
-license="GPL"
+options="!check" # Tests are known broken since 2009:
+# https://sourceforge.net/p/libcddb/bugs/7/
+license="LGPL-2.0+"
depends=
makedepends=
install=
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir"/$pkgname-$pkgver
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- # apply patches here
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}