aboutsummaryrefslogtreecommitdiffstats
path: root/main/libdrm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-19 07:28:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 07:28:11 +0000
commit5346fa571397f15505ccd1e8599331b2251cdadd (patch)
tree1e9d245e1a92c7b543e84c4847da625b0a1f3550 /main/libdrm
parentd8fe94954003e39da05c4eb85e2d9771adba2995 (diff)
downloadaports-5346fa571397f15505ccd1e8599331b2251cdadd.tar.bz2
aports-5346fa571397f15505ccd1e8599331b2251cdadd.tar.xz
main/libdrm: fix all symbol checks
Diffstat (limited to 'main/libdrm')
-rw-r--r--main/libdrm/APKBUILD6
-rw-r--r--main/libdrm/fix-kms-symbol-check.patch17
-rw-r--r--main/libdrm/fix-symbol-checks.patch212
3 files changed, 215 insertions, 20 deletions
diff --git a/main/libdrm/APKBUILD b/main/libdrm/APKBUILD
index 81149c2b75..a2b3745743 100644
--- a/main/libdrm/APKBUILD
+++ b/main/libdrm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdrm
pkgver=2.4.83
-pkgrel=1
+pkgrel=2
pkgdesc="Userspace interface to kernel DRM services"
url="http://dri.freedesktop.org/"
arch="all"
@@ -16,7 +16,7 @@ subpackages="$pkgname-dev"
source="http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2
ioctl.patch
amdgpu-uve_ib.patch
- fix-kms-symbol-check.patch
+ fix-symbol-checks.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -50,4 +50,4 @@ package() {
sha512sums="8f894ff61939bca03ac857506a84bbbcbe2367e60c91a0f2388bfce5ae81e12ba2f96fe1c962416cf9e2d25ef04b98b5437c7015497789561311a72607b3bfcb libdrm-2.4.83.tar.bz2
af52fef51aaa05a4dd17919371cb9d92a77480402730bf53ba223e54df52f3825be05a7f28e6aef8c904db5ee59fe38a6c15bc6aafa7f8d31a719e80399dd51f ioctl.patch
5aa56bf6dab6bec0f2fc90cba925bc64f48f0ebdf52651ccdbb65ccace99fce0bef23f7660968d54a6027ebc1f17850eb3a9cc5baa847c54f75a7b2b4b4e9f41 amdgpu-uve_ib.patch
-15aeee7ab7765ecdb487668f4930140643efd9731daf6406cb994c191f8c98c71c086e473915b2257d7ec5ce36965f48685a04e33878577f3a426e1919341150 fix-kms-symbol-check.patch"
+fe85537761fa8e7a168c2fbfcb6092ba3c34275c2eaa6c8ce2803ccc769a797350f8deacefc94a3479ebef51800808cdd4b4554eee14c1cd8b6f2cc159ab467e fix-symbol-checks.patch"
diff --git a/main/libdrm/fix-kms-symbol-check.patch b/main/libdrm/fix-kms-symbol-check.patch
deleted file mode 100644
index 6e888a3195..0000000000
--- a/main/libdrm/fix-kms-symbol-check.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/libkms/kms-symbol-check b/libkms/kms-symbol-check
-index 658b269..0885282 100755
---- a/libkms/kms-symbol-check
-+++ b/libkms/kms-symbol-check
-@@ -3,11 +3,8 @@
- # The following symbols (past the first five) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBKMS_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- kms_bo_create
diff --git a/main/libdrm/fix-symbol-checks.patch b/main/libdrm/fix-symbol-checks.patch
new file mode 100644
index 0000000000..67e9868f0f
--- /dev/null
+++ b/main/libdrm/fix-symbol-checks.patch
@@ -0,0 +1,212 @@
+diff --git a/amdgpu/amdgpu-symbol-check b/amdgpu/amdgpu-symbol-check
+index c5b85b5..c943282 100755
+--- a/amdgpu/amdgpu-symbol-check
++++ b/amdgpu/amdgpu-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.am/libdrm_amdgpuinclude_HEADERS
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_amdgpu.so} | awk '{print $3}' | while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_amdgpu.so} | awk '$2 == "T" {print $3}' | while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ amdgpu_bo_alloc
+diff --git a/etnaviv/etnaviv-symbol-check b/etnaviv/etnaviv-symbol-check
+index 0e2030e..3c32352 100755
+--- a/etnaviv/etnaviv-symbol-check
++++ b/etnaviv/etnaviv-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBDRM_ETNAVIV_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_etnaviv.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_etnaviv.so} | awk '$2 = "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ etna_device_new
+diff --git a/exynos/exynos-symbol-check b/exynos/exynos-symbol-check
+index 9692caa..2ab794e 100755
+--- a/exynos/exynos-symbol-check
++++ b/exynos/exynos-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.am/libdrm_exynos*_HEADERS
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_exynos.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_exynos.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ exynos_bo_create
+diff --git a/freedreno/freedreno-symbol-check b/freedreno/freedreno-symbol-check
+index 42f2c43..51de69c 100755
+--- a/freedreno/freedreno-symbol-check
++++ b/freedreno/freedreno-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_freedreno.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_freedreno.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ fd_bo_cpu_fini
+diff --git a/intel/intel-symbol-check b/intel/intel-symbol-check
+index 2aa2d81..21d951a 100755
+--- a/intel/intel-symbol-check
++++ b/intel/intel-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBDRM_INTEL_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_intel.so} | awk '{print $3}' | while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_intel.so} | awk '$2 == "T" {print $3}' | while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ drm_intel_bo_alloc
+diff --git a/libkms/kms-symbol-check b/libkms/kms-symbol-check
+index 658b269..e55963e 100755
+--- a/libkms/kms-symbol-check
++++ b/libkms/kms-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBKMS_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ kms_bo_create
+diff --git a/nouveau/nouveau-symbol-check b/nouveau/nouveau-symbol-check
+index b265cea..4417e99 100755
+--- a/nouveau/nouveau-symbol-check
++++ b/nouveau/nouveau-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBDRM_NOUVEAU_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_nouveau.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_nouveau.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ nouveau_bo_map
+diff --git a/omap/omap-symbol-check b/omap/omap-symbol-check
+index 759c84b..7ea96bb 100755
+--- a/omap/omap-symbol-check
++++ b/omap/omap-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.am/libdrm_omap*HEADERS
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_omap.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_omap.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ omap_bo_cpu_fini
+diff --git a/radeon/radeon-symbol-check b/radeon/radeon-symbol-check
+index 0bf2ffc..35e3ea1 100755
+--- a/radeon/radeon-symbol-check
++++ b/radeon/radeon-symbol-check
+@@ -1,13 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+-# The following symbols (past the first five) are taken from the public headers.
++# The following symbols (past the first two) are taken from the public headers.
+ # A list of the latter should be available Makefile.sources/LIBDRM_RADEON_H_FILES
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_radeon.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_radeon.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_start
+-_edata
+-_end
+ _fini
+ _init
+ radeon_bo_debug
+diff --git a/tegra/tegra-symbol-check b/tegra/tegra-symbol-check
+index 420469f..4c7094e 100755
+--- a/tegra/tegra-symbol-check
++++ b/tegra/tegra-symbol-check
+@@ -1,16 +1,9 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # The following symbols (past the first nine) are taken from tegra.h.
+
+-FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
++FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '$2 == "T" {print $3}'| while read func; do
+ ( grep -q "^$func$" || echo $func ) <<EOF
+-__bss_end__
+-__bss_start__
+-__bss_start
+-__end__
+-_bss_end__
+-_edata
+-_end
+ _fini
+ _init
+ drm_tegra_bo_get_flags