aboutsummaryrefslogtreecommitdiffstats
path: root/main/libdrm
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-08 14:00:06 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-11 07:14:24 +0000
commit7ba3523fe098c050e2729a4cd9a1fd50e2167aca (patch)
treee2951b0c4797b30e634b4f7f065b021c188c6763 /main/libdrm
parent67595378d8a2a18a5b013bdfcfd874b7df408d29 (diff)
downloadaports-7ba3523fe098c050e2729a4cd9a1fd50e2167aca.tar.bz2
aports-7ba3523fe098c050e2729a4cd9a1fd50e2167aca.tar.xz
main/libdrm: upgrade to 2.4.83 and add check
Diffstat (limited to 'main/libdrm')
-rw-r--r--main/libdrm/APKBUILD30
-rw-r--r--main/libdrm/amdgpu-uve_ib.patch536
-rw-r--r--main/libdrm/ioctl.patch11
3 files changed, 568 insertions, 9 deletions
diff --git a/main/libdrm/APKBUILD b/main/libdrm/APKBUILD
index 5db041c4d0..76e02efb89 100644
--- a/main/libdrm/APKBUILD
+++ b/main/libdrm/APKBUILD
@@ -1,19 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdrm
-pkgver=2.4.81
-pkgrel=1
+pkgver=2.4.83
+pkgrel=0
pkgdesc="Userspace interface to kernel DRM services"
url="http://dri.freedesktop.org/"
arch="all"
license="custom"
depends=""
depends_dev="linux-headers"
-makedepends="$depends_dev libpthread-stubs eudev-dev libpciaccess-dev"
+#remove automake, autoconf and util-macros from makedepends in next release
+makedepends="$depends_dev libpthread-stubs eudev-dev libpciaccess-dev
+ automake autoconf util-macros"
+checkdepends="cunit-dev"
subpackages="$pkgname-dev"
source="http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2
+ ioctl.patch
+ amdgpu-uve_ib.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
./configure \
@@ -26,14 +32,20 @@ build() {
--enable-freedreno \
--enable-udev \
--disable-manpages \
- --disable-valgrind \
- || return 1
- make || return 1
+ --disable-valgrind
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="5f7a1524acad59890d3f890bed90a660a424e18a88d587ca356223bde4a7446d1c540f97ec11cb10d2e7ed1b4ae86127957634354a1be6d04199295ab24782e5 libdrm-2.4.81.tar.bz2"
+sha512sums="8f894ff61939bca03ac857506a84bbbcbe2367e60c91a0f2388bfce5ae81e12ba2f96fe1c962416cf9e2d25ef04b98b5437c7015497789561311a72607b3bfcb libdrm-2.4.83.tar.bz2
+af52fef51aaa05a4dd17919371cb9d92a77480402730bf53ba223e54df52f3825be05a7f28e6aef8c904db5ee59fe38a6c15bc6aafa7f8d31a719e80399dd51f ioctl.patch
+5aa56bf6dab6bec0f2fc90cba925bc64f48f0ebdf52651ccdbb65ccace99fce0bef23f7660968d54a6027ebc1f17850eb3a9cc5baa847c54f75a7b2b4b4e9f41 amdgpu-uve_ib.patch"
diff --git a/main/libdrm/amdgpu-uve_ib.patch b/main/libdrm/amdgpu-uve_ib.patch
new file mode 100644
index 0000000000..153e0ec5b4
--- /dev/null
+++ b/main/libdrm/amdgpu-uve_ib.patch
@@ -0,0 +1,536 @@
+diff --git a/tests/amdgpu/uve_ib.h b/tests/amdgpu/uve_ib.h
+new file mode 100644
+index 0000000..9abd406
+--- /dev/null
++++ b/tests/amdgpu/uve_ib.h
+@@ -0,0 +1,527 @@
++/*
++ * Copyright 2017 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++*/
++
++#ifndef _uve_ib_h_
++#define _uve_ib_h_
++
++static const uint32_t uve_session_info[] = {
++ 0x00000018,
++ 0x00000001,
++ 0x00000000,
++ 0x00010000,
++};
++
++static const uint32_t uve_task_info[] = {
++ 0x00000014,
++ 0x00000002,
++};
++
++static const uint32_t uve_session_init[] = {
++ 0x00000020,
++ 0x00000003,
++ 0x000000c0,
++ 0x00000080,
++ 0x00000020,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_layer_ctrl[] = {
++ 0x00000010,
++ 0x00000004,
++ 0x00000001,
++ 0x00000001,
++};
++
++static const uint32_t uve_layer_select[] = {
++ 0x0000000c,
++ 0x00000005,
++ 0x00000000,
++};
++
++static const uint32_t uve_slice_ctrl[] = {
++ 0x00000014,
++ 0x00000006,
++ 0x00000000,
++ 0x00000006,
++ 0x00000006,
++};
++
++static const uint32_t uve_spec_misc[] = {
++ 0x00000024,
++ 0x00000007,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000001,
++ 0x00000001,
++};
++
++static const uint32_t uve_rc_session_init[] = {
++ 0x00000010,
++ 0x00000008,
++ 0x00000000,
++ 0x00000040,
++};
++
++static const uint32_t uve_rc_layer_init[] = {
++ 0x00000028,
++ 0x00000009,
++ 0x001e8480,
++ 0x001e8480,
++ 0x0000001e,
++ 0x00000001,
++ 0x0001046a,
++ 0x0001046a,
++ 0x0001046a,
++ 0xaaaaaaaa,
++};
++
++static const uint32_t uve_deblocking_filter[] = {
++ 0x00000020,
++ 0x0000000e,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_quality_params[] = {
++ 0x00000014,
++ 0x0000000d,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_feedback_buffer[] = {
++ 0x0000001c,
++ 0x00000012,
++ 0x00000000,
++};
++
++static const uint32_t uve_feedback_buffer_additional[] = {
++ 0x00000108,
++ 0x00000014,
++ 0x00000001,
++ 0x00000010,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_nalu_buffer_1[] = {
++ 0x00000018,
++ 0x00000013,
++ 0x00000001,
++ 0x00000007,
++ 0x00000001,
++ 0x46011000,
++};
++
++static const uint32_t uve_nalu_buffer_2[] = {
++ 0x0000002c,
++ 0x00000013,
++ 0x00000002,
++ 0x0000001b,
++ 0x00000001,
++ 0x40010c01,
++ 0xffff0160,
++ 0x00000300,
++ 0xb0000003,
++ 0x00000300,
++ 0x962c0900,
++};
++
++static const uint32_t uve_nalu_buffer_3[] = {
++ 0x00000034,
++ 0x00000013,
++ 0x00000003,
++ 0x00000023,
++ 0x00000001,
++ 0x42010101,
++ 0x60000003,
++ 0x00b00000,
++ 0x03000003,
++ 0x0096a018,
++ 0x2020708f,
++ 0xcb924295,
++ 0x12e08000,
++};
++
++static const uint32_t uve_nalu_buffer_4[] = {
++ 0x0000001c,
++ 0x00000013,
++ 0x00000004,
++ 0x0000000b,
++ 0x00000001,
++ 0x4401e0f1,
++ 0x80992000,
++};
++
++static const uint32_t uve_slice_header[] = {
++ 0x000000c8,
++ 0x0000000b,
++ 0x28010000,
++ 0x40000000,
++ 0x60000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000002,
++ 0x00000010,
++ 0x00000003,
++ 0x00000000,
++ 0x00000002,
++ 0x00000002,
++ 0x00000004,
++ 0x00000000,
++ 0x00000001,
++ 0x00000000,
++ 0x00000002,
++ 0x00000003,
++ 0x00000005,
++ 0x00000000,
++ 0x00000002,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_encode_param[] = {
++ 0x000000a0,
++ 0x00000080,
++ 0x00000000,
++ 0x00000000,
++ 0xffffffff,
++ 0x00000001,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_intra_refresh[] = {
++ 0x00000014,
++ 0x0000000f,
++ 0x00000000,
++ 0x00000000,
++ 0x00000001,
++};
++
++static const uint32_t uve_ctx_buffer[] = {
++ 0x00000000,
++ 0x00000000,
++ 0x000000a0,
++ 0x000000a0,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++};
++
++static const uint32_t uve_bitstream_buffer[] = {
++ 0x0000001c,
++ 0x00000011,
++};
++
++static const uint32_t uve_rc_per_pic[] = {
++ 0x00000024,
++ 0x0000000a,
++ 0x0000001a,
++ 0x00000000,
++ 0x00000033,
++ 0x00000000,
++ 0x00000000,
++ 0x00000000,
++ 0x00000001,
++};
++
++static const uint32_t uve_op_init[] = {
++ 0x00000008,
++ 0x08000001,
++};
++
++static const uint32_t uve_op_close[] = {
++ 0x00000008,
++ 0x08000002,
++};
++
++static const uint32_t uve_op_encode[] = {
++ 0x00000008,
++ 0x08000003,
++};
++
++static const uint32_t uve_op_init_rc[] = {
++ 0x00000008,
++ 0x08000004,
++};
++
++static const uint32_t uve_op_init_rc_vbv_level[] = {
++ 0x00000008,
++ 0x08000005,
++};
++
++static const uint32_t uve_op_speed_enc_mode[] = {
++ 0x00000008,
++ 0x08000006,
++};
++
++static const uint32_t uve_op_balance_enc_mode[] = {
++ 0x00000008,
++ 0x08000007,
++};
++
++static const uint32_t uve_op_quality_enc_mode[] = {
++ 0x00000008,
++ 0x08000008,
++};
++#endif /*_uve_ib_h*/
+--
+cgit v0.10.2
+
diff --git a/main/libdrm/ioctl.patch b/main/libdrm/ioctl.patch
new file mode 100644
index 0000000000..9ffe5f9335
--- /dev/null
+++ b/main/libdrm/ioctl.patch
@@ -0,0 +1,11 @@
+--- libdrm-2.4.83/tests/nouveau/threaded.c
++++ libdrm-2.4.83/tests/nouveau/threaded.c
+@@ -40,7 +40,7 @@
+
+ static int import_fd;
+
+-int ioctl(int fd, unsigned long request, ...)
++int ioctl(int fd, int request, ...)
+ {
+ va_list va;
+ int ret;