aboutsummaryrefslogtreecommitdiffstats
path: root/main/libdrm
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-06-03 16:48:12 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-12 12:27:29 +0000
commita984acf904a2a539ae6f08cf2546600d6a7581f2 (patch)
treebc647f77696e0551c28ecf26b334275d86ba53c2 /main/libdrm
parentd0fb9892020006b0cc4137a186c9f009a1a7dab9 (diff)
downloadaports-a984acf904a2a539ae6f08cf2546600d6a7581f2.tar.bz2
aports-a984acf904a2a539ae6f08cf2546600d6a7581f2.tar.xz
main/libdrm: Upgrade to 2.4.92
Diffstat (limited to 'main/libdrm')
-rw-r--r--main/libdrm/APKBUILD10
-rw-r--r--main/libdrm/fix-symbol-checks.patch212
2 files changed, 4 insertions, 218 deletions
diff --git a/main/libdrm/APKBUILD b/main/libdrm/APKBUILD
index 5f5eab8ddd..24f586dde9 100644
--- a/main/libdrm/APKBUILD
+++ b/main/libdrm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdrm
-pkgver=2.4.89
-pkgrel=2
+pkgver=2.4.92
+pkgrel=0
pkgdesc="Userspace interface to kernel DRM services"
url="https://dri.freedesktop.org/"
arch="all"
@@ -15,7 +15,6 @@ checkdepends="cunit-dev bash"
subpackages="$pkgname-dev $pkgname-doc"
source="https://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2
ioctl.patch
- fix-symbol-checks.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -45,6 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="380e4e46cd3971a73264bd1b482791fab0503268adb65ac81b674df009662cfb8ef5741e362f19670b2a43b1c46f022d857706c9a4bebed2b1cddaa317b7706d libdrm-2.4.89.tar.bz2
-af52fef51aaa05a4dd17919371cb9d92a77480402730bf53ba223e54df52f3825be05a7f28e6aef8c904db5ee59fe38a6c15bc6aafa7f8d31a719e80399dd51f ioctl.patch
-fe85537761fa8e7a168c2fbfcb6092ba3c34275c2eaa6c8ce2803ccc769a797350f8deacefc94a3479ebef51800808cdd4b4554eee14c1cd8b6f2cc159ab467e fix-symbol-checks.patch"
+sha512sums="9b75584d8957d298125884d490b74c0a641725d17088ba47f3dc2ec9d06519d8387eb464c024ee11712b31b17fb84e1a9a52bd4ebc7c316beb7d2f8711dc9eb2 libdrm-2.4.92.tar.bz2
+af52fef51aaa05a4dd17919371cb9d92a77480402730bf53ba223e54df52f3825be05a7f28e6aef8c904db5ee59fe38a6c15bc6aafa7f8d31a719e80399dd51f ioctl.patch"
diff --git a/main/libdrm/fix-symbol-checks.patch b/main/libdrm/fix-symbol-checks.patch
deleted file mode 100644
index 67e9868f0f..0000000000
--- a/main/libdrm/fix-symbol-checks.patch
+++ /dev/null
@@ -1,212 +0,0 @@
-diff --git a/amdgpu/amdgpu-symbol-check b/amdgpu/amdgpu-symbol-check
-index c5b85b5..c943282 100755
---- a/amdgpu/amdgpu-symbol-check
-+++ b/amdgpu/amdgpu-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.am/libdrm_amdgpuinclude_HEADERS
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_amdgpu.so} | awk '{print $3}' | while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_amdgpu.so} | awk '$2 == "T" {print $3}' | while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- amdgpu_bo_alloc
-diff --git a/etnaviv/etnaviv-symbol-check b/etnaviv/etnaviv-symbol-check
-index 0e2030e..3c32352 100755
---- a/etnaviv/etnaviv-symbol-check
-+++ b/etnaviv/etnaviv-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_ETNAVIV_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_etnaviv.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_etnaviv.so} | awk '$2 = "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- etna_device_new
-diff --git a/exynos/exynos-symbol-check b/exynos/exynos-symbol-check
-index 9692caa..2ab794e 100755
---- a/exynos/exynos-symbol-check
-+++ b/exynos/exynos-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.am/libdrm_exynos*_HEADERS
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_exynos.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_exynos.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- exynos_bo_create
-diff --git a/freedreno/freedreno-symbol-check b/freedreno/freedreno-symbol-check
-index 42f2c43..51de69c 100755
---- a/freedreno/freedreno-symbol-check
-+++ b/freedreno/freedreno-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_freedreno.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_freedreno.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- fd_bo_cpu_fini
-diff --git a/intel/intel-symbol-check b/intel/intel-symbol-check
-index 2aa2d81..21d951a 100755
---- a/intel/intel-symbol-check
-+++ b/intel/intel-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_INTEL_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_intel.so} | awk '{print $3}' | while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_intel.so} | awk '$2 == "T" {print $3}' | while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- drm_intel_bo_alloc
-diff --git a/libkms/kms-symbol-check b/libkms/kms-symbol-check
-index 658b269..e55963e 100755
---- a/libkms/kms-symbol-check
-+++ b/libkms/kms-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBKMS_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- kms_bo_create
-diff --git a/nouveau/nouveau-symbol-check b/nouveau/nouveau-symbol-check
-index b265cea..4417e99 100755
---- a/nouveau/nouveau-symbol-check
-+++ b/nouveau/nouveau-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_NOUVEAU_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_nouveau.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_nouveau.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- nouveau_bo_map
-diff --git a/omap/omap-symbol-check b/omap/omap-symbol-check
-index 759c84b..7ea96bb 100755
---- a/omap/omap-symbol-check
-+++ b/omap/omap-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.am/libdrm_omap*HEADERS
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_omap.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_omap.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- omap_bo_cpu_fini
-diff --git a/radeon/radeon-symbol-check b/radeon/radeon-symbol-check
-index 0bf2ffc..35e3ea1 100755
---- a/radeon/radeon-symbol-check
-+++ b/radeon/radeon-symbol-check
-@@ -1,13 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
-
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first two) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_RADEON_H_FILES
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_radeon.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_radeon.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_start
--_edata
--_end
- _fini
- _init
- radeon_bo_debug
-diff --git a/tegra/tegra-symbol-check b/tegra/tegra-symbol-check
-index 420469f..4c7094e 100755
---- a/tegra/tegra-symbol-check
-+++ b/tegra/tegra-symbol-check
-@@ -1,16 +1,9 @@
--#!/bin/bash
-+#!/bin/sh
-
- # The following symbols (past the first nine) are taken from tegra.h.
-
--FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
-+FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '$2 == "T" {print $3}'| while read func; do
- ( grep -q "^$func$" || echo $func ) <<EOF
--__bss_end__
--__bss_start__
--__bss_start
--__end__
--_bss_end__
--_edata
--_end
- _fini
- _init
- drm_tegra_bo_get_flags