aboutsummaryrefslogtreecommitdiffstats
path: root/main/libdvbpsi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-17 11:34:33 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-17 11:34:33 +0000
commit7f1b8389aa0564a7b44661485f9841d34caad980 (patch)
tree7dbabfa40bbc746672dacda3f072ebf3dcae99df /main/libdvbpsi
parent073955c10e00e2eaabf70c3215686ef9e9b457c5 (diff)
downloadaports-7f1b8389aa0564a7b44661485f9841d34caad980.tar.bz2
aports-7f1b8389aa0564a7b44661485f9841d34caad980.tar.xz
main/libdvbpsi: fix musl build
Diffstat (limited to 'main/libdvbpsi')
-rw-r--r--main/libdvbpsi/APKBUILD19
-rw-r--r--main/libdvbpsi/fix-includes.patch24
2 files changed, 39 insertions, 4 deletions
diff --git a/main/libdvbpsi/APKBUILD b/main/libdvbpsi/APKBUILD
index 4ffb07f4c6..48a543ea14 100644
--- a/main/libdvbpsi/APKBUILD
+++ b/main/libdvbpsi/APKBUILD
@@ -9,14 +9,22 @@ license="GPL"
depends=
makedepends=""
subpackages="$pkgname-dev"
-source="http://download.videolan.org/pub/libdvbpsi/$pkgver/$pkgname-$pkgver.tar.bz2"
+source="http://download.videolan.org/pub/libdvbpsi/$pkgver/$pkgname-$pkgver.tar.bz2
+ fix-includes.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
+
build() {
cd "$_builddir"
./configure \
@@ -33,6 +41,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
}
-md5sums="0c7c355201f325ea99c522d8ec97bf86 libdvbpsi-1.1.1.tar.bz2"
-sha256sums="4e06fa581d9b3693682428bc4f8bb8df97151c9e57baae72322057d260c3e6fd libdvbpsi-1.1.1.tar.bz2"
-sha512sums="d758b6e2181e991e450d5bbc8d9682535ec395c8db90704125b8ec6a3975d8f0239bf5d495454c9bb81e08e924ed3c18d408bbabee1da7e7ace9a3d0460feb32 libdvbpsi-1.1.1.tar.bz2"
+md5sums="0c7c355201f325ea99c522d8ec97bf86 libdvbpsi-1.1.1.tar.bz2
+0f238bf0adb647785f466927d9c37d3d fix-includes.patch"
+sha256sums="4e06fa581d9b3693682428bc4f8bb8df97151c9e57baae72322057d260c3e6fd libdvbpsi-1.1.1.tar.bz2
+0d0fdd1cf6e567558a1357d9e2e82124bfa273c3cd6c64fb70747660f52931fe fix-includes.patch"
+sha512sums="d758b6e2181e991e450d5bbc8d9682535ec395c8db90704125b8ec6a3975d8f0239bf5d495454c9bb81e08e924ed3c18d408bbabee1da7e7ace9a3d0460feb32 libdvbpsi-1.1.1.tar.bz2
+f612bf80b07ec37a83477a37d78971c4bd4331eec86686a8bc7b247f43df2c047c89de419d5cef0b960de2032daedc81a4c380802c76b4dc081e1c09ad364dcb fix-includes.patch"
diff --git a/main/libdvbpsi/fix-includes.patch b/main/libdvbpsi/fix-includes.patch
new file mode 100644
index 0000000000..9fbdc8455a
--- /dev/null
+++ b/main/libdvbpsi/fix-includes.patch
@@ -0,0 +1,24 @@
+--- libdvbpsi-1.1.1.orig/examples/dvbinfo/buffer.h
++++ libdvbpsi-1.1.1/examples/dvbinfo/buffer.h
+@@ -23,6 +23,9 @@
+ #ifndef DVBINFO_BUFFER_H_
+ #define DVBINFO_BUFFER_H_
+
++#include <sys/types.h>
++#include <stdint.h>
++
+ typedef struct buffer_s buffer_t;
+
+ struct buffer_s
+--- libdvbpsi-1.1.1.orig/src/descriptor.h
++++ libdvbpsi-1.1.1/src/descriptor.h
+@@ -35,6 +35,9 @@
+ #ifndef _DVBPSI_DESCRIPTOR_H_
+ #define _DVBPSI_DESCRIPTOR_H_
+
++#include <sys/types.h>
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif