aboutsummaryrefslogtreecommitdiffstats
path: root/main/libdvdcss
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-12 14:06:28 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-12 14:30:15 +0000
commitb590addc0b11727dff69b5c9f77f286735ded699 (patch)
tree5416161aa16e280323dcbee7ff042d332321a1b7 /main/libdvdcss
parentb78aca01e9a5e941b35138d32dd02465ddc9e88d (diff)
downloadaports-b590addc0b11727dff69b5c9f77f286735ded699.tar.bz2
aports-b590addc0b11727dff69b5c9f77f286735ded699.tar.xz
main/libdvdcss: new aport
Library for reading encrypted DVDs
Diffstat (limited to 'main/libdvdcss')
-rw-r--r--main/libdvdcss/APKBUILD40
-rw-r--r--main/libdvdcss/replace-error.patch101
2 files changed, 141 insertions, 0 deletions
diff --git a/main/libdvdcss/APKBUILD b/main/libdvdcss/APKBUILD
new file mode 100644
index 0000000000..a81c243f66
--- /dev/null
+++ b/main/libdvdcss/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=libdvdcss
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Library for accessing DVDs like a block device without having to bother about the decryption"
+url="http://www.videolan.org/developers/libdvdcss.html"
+arch="all"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.videolan.org/pub/libdvdcss/$pkgver/libdvdcss-$pkgver.tar.bz2
+ replace-error.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="ad4503a37f47a9563da0b9e387ca3e812f6cdfbf109b8d92f8eccdd879b4270e5b0ee79041d7fb4c86698d72748f7bbf0257db8da6bb1c889dd4f78645e3371b libdvdcss-1.4.0.tar.bz2
+6aa9510b662d39527935f90fc500d27a8ff6bfc45a967ee3b3affcb0637a3d9ce9acb0967e88c65711a74eeb2061c63b14c542ec47b1dded29a5729f7e659f8e replace-error.patch"
diff --git a/main/libdvdcss/replace-error.patch b/main/libdvdcss/replace-error.patch
new file mode 100644
index 0000000000..194fef0054
--- /dev/null
+++ b/main/libdvdcss/replace-error.patch
@@ -0,0 +1,101 @@
+--- a/src/ioctl.c
++++ b/src/ioctl.c
+@@ -220,7 +220,7 @@
+ *pi_copyright = p_buffer[ 4 ];
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -353,7 +353,7 @@
+ memcpy( p_key, p_buffer + 4, DVD_DISCKEY_SIZE );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -483,7 +483,7 @@
+ memcpy( p_key, p_buffer + 5, DVD_KEY_SIZE );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+
+@@ -580,7 +580,7 @@
+ *pi_agid = p_buffer[ 7 ] >> 6;
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -688,7 +688,7 @@
+ memcpy( p_challenge, p_buffer + 4, DVD_CHALLENGE_SIZE );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -798,7 +798,7 @@
+ *pi_asf = p_buffer[ 7 ] & 1;
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -901,7 +901,7 @@
+ memcpy( p_key, p_buffer + 4, DVD_KEY_SIZE );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -984,7 +984,7 @@
+ &sdc, sizeof(sdc), &ulParamLen,
+ NULL, 0, &ulDataLen);
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -1093,7 +1093,7 @@
+ p_buffer, sizeof(p_buffer), &ulDataLen );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -1202,7 +1202,7 @@
+ p_buffer, sizeof(p_buffer), &ulDataLen );
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;
+@@ -1329,7 +1329,7 @@
+ *p_scheme = p_buffer[ 6 ];
+
+ #else
+-# error "DVD ioctls are unavailable on this system"
++ printf("DVD ioctls are unavailable on this system\n");
+
+ #endif
+ return i_ret;