aboutsummaryrefslogtreecommitdiffstats
path: root/main/libevent
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-03-28 22:09:27 -0400
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 06:28:52 +0000
commite7e38e3a1f43ba15d77806555854eb9da38d892c (patch)
treeeb7265a1d3ade213da402f033acd1a7501ccf186 /main/libevent
parent57f061b63a43823bcb48888eefa9e96b13c46a12 (diff)
downloadaports-e7e38e3a1f43ba15d77806555854eb9da38d892c.tar.bz2
aports-e7e38e3a1f43ba15d77806555854eb9da38d892c.tar.xz
main/libevent: add disabled check
Diffstat (limited to 'main/libevent')
-rw-r--r--main/libevent/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/main/libevent/APKBUILD b/main/libevent/APKBUILD
index 3cee00568c..0ae76a019d 100644
--- a/main/libevent/APKBUILD
+++ b/main/libevent/APKBUILD
@@ -8,6 +8,7 @@ pkgdesc="An event notification library"
url="http://libevent.org/"
arch="all"
license="BSD-3-Clause"
+options="!check" # regression tests failed
depends_dev="python2"
makedepends="$depends_dev libressl-dev"
subpackages="$pkgname-dev"
@@ -40,6 +41,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make -j1 check
+}
+
package() {
cd "$builddir"
make -j1 DESTDIR=$pkgdir install