aboutsummaryrefslogtreecommitdiffstats
path: root/main/libexif
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 22:09:26 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:27:10 +0000
commit3049df94807f447aca4e01de628085efd06c9dd4 (patch)
treed87f91573607a609034331318cce78fe97771f16 /main/libexif
parent3ebee591b5f40c2ad5c54af139642e80c5ba517d (diff)
downloadaports-3049df94807f447aca4e01de628085efd06c9dd4.tar.bz2
aports-3049df94807f447aca4e01de628085efd06c9dd4.tar.xz
main/libexif: modernise, add check, fix license
Diffstat (limited to 'main/libexif')
-rw-r--r--main/libexif/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/main/libexif/APKBUILD b/main/libexif/APKBUILD
index ff0e637812..a18e1b7fe7 100644
--- a/main/libexif/APKBUILD
+++ b/main/libexif/APKBUILD
@@ -1,35 +1,38 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libexif
pkgver=0.6.21
-pkgrel=1
+pkgrel=2
pkgdesc="A library to parse an EXIF file and read the data from those tags"
url="https://sourceforge.net/projects/libexif"
arch="all"
-license="LGPL"
+license="LGPL-2.0+"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends=
source="http://downloads.sf.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
+ --prefix=/usr
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="4e0fe2abe85d1c95b41cb3abe1f6333dc3a9eb69dba106a674a78d74a4d5b9c5a19647118fa1cc2d72b98a29853394f1519eda9e2889eb28d3be26b21c7cfc35 libexif-0.6.21.tar.bz2"