aboutsummaryrefslogtreecommitdiffstats
path: root/main/libgcrypt
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-02-26 13:43:47 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-02-26 13:43:47 +0000
commit940d417f509901b8c31d54ba4aac6e87438bb1cf (patch)
treec14a9ccce6c60d6fe9285310fde24df79564cfa2 /main/libgcrypt
parent899733ab8cf3817c38d0bb890c01122d5c441e9b (diff)
downloadaports-940d417f509901b8c31d54ba4aac6e87438bb1cf.tar.bz2
aports-940d417f509901b8c31d54ba4aac6e87438bb1cf.tar.xz
main/libgcrypt: fix arm build
Diffstat (limited to 'main/libgcrypt')
-rw-r--r--main/libgcrypt/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/main/libgcrypt/APKBUILD b/main/libgcrypt/APKBUILD
index cd25b0a181..d6aea8500b 100644
--- a/main/libgcrypt/APKBUILD
+++ b/main/libgcrypt/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgcrypt
pkgver=1.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="general purpose crypto library based on the code used in GnuPG"
url="http://www.gnupg.org"
arch="all"
@@ -14,14 +14,26 @@ source="ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-$pkgver.tar.bz2"
build () {
+ local _arch_configure=
+
cd "$srcdir"/$pkgname-$pkgver
+ case "$CARCH" in
+ arm*)
+ # disable arm assembly for now as it produces TEXTRELs
+ export gcry_cv_gcc_arm_platform_as_ok=no
+ ;;
+ x86 | x86_64)
+ _arch_configure="--enable-padlock-support"
+ ;;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --enable-padlock-support \
--disable-static \
+ $_arch_configure \
|| return 1
make || return 1