aboutsummaryrefslogtreecommitdiffstats
path: root/main/libgnome
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-17 14:26:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-17 14:27:19 +0000
commit761e6c641738a068f8ce90090230816d14f1518a (patch)
tree10d7bbe12f8ae9ad59605f1c8329257ffe468816 /main/libgnome
parentfd790d7c5ba9ed3c5aacf8a0d5bd7d12ca3b913d (diff)
downloadaports-761e6c641738a068f8ce90090230816d14f1518a.tar.bz2
aports-761e6c641738a068f8ce90090230816d14f1518a.tar.xz
main/libgnome: fix invalid utf-8 in header and modernize
it breaks the new python glib-mkenums
Diffstat (limited to 'main/libgnome')
-rw-r--r--main/libgnome/0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch26
-rw-r--r--main/libgnome/APKBUILD37
2 files changed, 40 insertions, 23 deletions
diff --git a/main/libgnome/0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch b/main/libgnome/0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch
new file mode 100644
index 0000000000..f2885386aa
--- /dev/null
+++ b/main/libgnome/0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch
@@ -0,0 +1,26 @@
+From 33313713c4f5c1de500859ff128d6fd7e3af5722 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Mon, 7 Aug 2017 12:57:43 -0400
+Subject: [PATCH] gnome-config.h: Fix invalid UTF-8 in header
+
+This breaks the new Python `glib-mkenums`.
+---
+ libgnome/gnome-config.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgnome/gnome-config.h b/libgnome/gnome-config.h
+index 0c3dfe64..b9d659d4 100644
+--- a/libgnome/gnome-config.h
++++ b/libgnome/gnome-config.h
+@@ -270,7 +270,7 @@ void gnome_config_clean_key_ (const char *path, gboolean priv);
+ #define gnome_config_private_clean_key(path) \
+ (gnome_config_clean_key_((path),TRUE))
+
+-/* returns the true filename of the config file */
++/* returns the true filename of the config file */
+ #define gnome_config_get_real_path(path) \
+ (g_build_filename (gnome_user_dir_get(),(path),NULL))
+ #define gnome_config_private_get_real_path(path) \
+--
+2.13.4
+
diff --git a/main/libgnome/APKBUILD b/main/libgnome/APKBUILD
index 1ee192d75d..cbf0ac4aba 100644
--- a/main/libgnome/APKBUILD
+++ b/main/libgnome/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgnome
pkgver=2.32.1
-pkgrel=6
+pkgrel=7
pkgdesc="GNOME base library"
url="http://www.gnome.org/"
arch="all"
@@ -13,41 +13,32 @@ makedepends="$depends_dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
- glib-2.36.patch"
+ glib-2.36.patch
+ 0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch
+ "
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc \
- || return 1
- make || return 1
+ --sysconfdir=/etc
+ make
}
package() {
- cd "$_builddir"
-
+ cd "$builddir"
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="a4345e6087ae6195d65a4674ffdca559 libgnome-2.32.1.tar.bz2
-67e4f7b0acea497406f06b04df608982 glib-2.36.patch"
-sha256sums="b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4 libgnome-2.32.1.tar.bz2
-a0895e37c81f5f45c0f05931416ddbad6284735eded43b75dc8d0947a5bddd55 glib-2.36.patch"
sha512sums="f94e603255a93e73249e0fd9ed5604d732b44ad46f3cc3065afb46fc6162f6cf29304f49440b5c06303b8e68608b6fd16236076813febb5f1cbdcde4bfc3b3e3 libgnome-2.32.1.tar.bz2
-1c7ed4c8012584c980f80ce12ee2e8ab1340432766b35b3139844927e183ef33d09a02eb7ec10bb8c7312950d2c1d0d1bdeef92512cded2278223470b2936087 glib-2.36.patch"
+1c7ed4c8012584c980f80ce12ee2e8ab1340432766b35b3139844927e183ef33d09a02eb7ec10bb8c7312950d2c1d0d1bdeef92512cded2278223470b2936087 glib-2.36.patch
+c327834d533bc8d816685a3b89ba5924d1d3e04be0fa1a38f6f3a3bc0de86f06062a8cde80cee3c91eee2803a61a531991c900829592adfddb6a2611b925d5c4 0001-gnome-config.h-Fix-invalid-UTF-8-in-header.patch"