aboutsummaryrefslogtreecommitdiffstats
path: root/main/libical
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 12:25:15 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 11:51:45 +0000
commite5cf633d399b278b34c95c317462e69bf9df7468 (patch)
treed0da931d67efbf5616e781e0f04ad38bb02c2fe8 /main/libical
parentb48c215955dd4933516ae4bf5b6b26f7a3b16f27 (diff)
downloadaports-e5cf633d399b278b34c95c317462e69bf9df7468.tar.bz2
aports-e5cf633d399b278b34c95c317462e69bf9df7468.tar.xz
main/libical: modernize abuild
Diffstat (limited to 'main/libical')
-rw-r--r--main/libical/APKBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/main/libical/APKBUILD b/main/libical/APKBUILD
index 74c69c0590..6d99f65981 100644
--- a/main/libical/APKBUILD
+++ b/main/libical/APKBUILD
@@ -3,41 +3,27 @@ pkgname=libical
pkgver=2.0.0
pkgrel=0
pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
-url="http://sourceforge.net/projects/freeassociation/"
+url="https://libical.github.io/libical/"
arch="all"
license="LGPL MPL"
-depends=
+depends=""
makedepends="perl cmake"
subpackages="$pkgname-dev"
source="https://github.com/libical/libical/releases/download/v$pkgver/libical-$pkgver.tar.gz"
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
-
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd $builddir
cmake -DCMAKE_RELEASE_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DSHARED_ONLY=true \
- || return 1
- make || return 1
+ -DSHARED_ONLY=true
+ make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd $builddir
make DESTDIR="$pkgdir" install
}
-md5sums="6bf8e5f5a3ba88baf390d0134e05d76e libical-2.0.0.tar.gz"
-sha256sums="654c11f759c19237be39f6ad401d917e5a05f36f1736385ed958e60cf21456da libical-2.0.0.tar.gz"
sha512sums="06318512d5df25e97f64b0e82ade6eaa41e42a428641642ecb8973dc23b172698a8ff8734b7e12b033b1278a131c6339d208e1bfd1bcba0a2c9519a01749a55f libical-2.0.0.tar.gz"