aboutsummaryrefslogtreecommitdiffstats
path: root/main/libice
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/libice
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
downloadaports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.bz2
aports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.xz
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/libice')
-rw-r--r--main/libice/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/main/libice/APKBUILD b/main/libice/APKBUILD
index 50023319de..1ae34ce073 100644
--- a/main/libice/APKBUILD
+++ b/main/libice/APKBUILD
@@ -7,13 +7,20 @@ url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
depends=
+depends_dev="xproto"
makedepends="pkgconfig xproto xtrans"
subpackages="$pkgname-dev"
source="http://xorg.freedesktop.org/releases/individual/lib/libICE-$pkgver.tar.bz2"
-depends_dev="xproto"
-build () {
- cd "$srcdir"/libICE-$pkgver
+_builddir="$srcdir/libICE-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \