aboutsummaryrefslogtreecommitdiffstats
path: root/main/libinput
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-03 12:49:40 +0300
committerSören Tempel <soeren+git@soeren-tempel.net>2018-07-06 08:43:44 +0200
commiteb4b17a9c407a51d37f347f7925811d12e751692 (patch)
tree0c99b1342d77b85fb77512cbd12703980286839c /main/libinput
parente5b552b8412fd68493840175ec8409e353bc1c91 (diff)
downloadaports-eb4b17a9c407a51d37f347f7925811d12e751692.tar.bz2
aports-eb4b17a9c407a51d37f347f7925811d12e751692.tar.xz
main/libinput: upgrade to 1.11.2
Diffstat (limited to 'main/libinput')
-rw-r--r--main/libinput/0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch58
-rw-r--r--main/libinput/APKBUILD10
2 files changed, 4 insertions, 64 deletions
diff --git a/main/libinput/0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch b/main/libinput/0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch
deleted file mode 100644
index de19ca2051..0000000000
--- a/main/libinput/0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 7c51c881dc72827ca50ae9eea3d123eef9cb4a66 Mon Sep 17 00:00:00 2001
-From: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed, 20 Jun 2018 07:56:05 +1000
-Subject: [PATCH] tools: pass a valid grab parameter to list-devices
-
-My kingdome for a compiler warning. Or a scan-build warning. Or a coverity
-warning. Or anything... But no, nothing.
-
-Also make the open_restricted() more robust to a NULL userdata, because
-effectively that's what we were passing here.
-
-Fixes https://gitlab.freedesktop.org/libinput/libinput/issues/50
-
-Introduced in 0a13223c39fdf0f079715bf83d498c0dcd9cf4f8
-
-Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
----
- tools/libinput-list-devices.c | 3 ++-
- tools/shared.c | 2 +-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/tools/libinput-list-devices.c b/tools/libinput-list-devices.c
-index aa225ca0..4cbdf775 100644
---- a/tools/libinput-list-devices.c
-+++ b/tools/libinput-list-devices.c
-@@ -372,6 +372,7 @@ main(int argc, char **argv)
- {
- struct libinput *li;
- struct libinput_event *ev;
-+ bool grab = false;
-
- /* This is kept for backwards-compatibility with the old
- libinput-list-devices */
-@@ -388,7 +389,7 @@ main(int argc, char **argv)
- }
- }
-
-- li = tools_open_backend(BACKEND_UDEV, "seat0", false, false);
-+ li = tools_open_backend(BACKEND_UDEV, "seat0", false, &grab);
- if (!li)
- return 1;
-
-diff --git a/tools/shared.c b/tools/shared.c
-index d1f02702..d3fb6294 100644
---- a/tools/shared.c
-+++ b/tools/shared.c
-@@ -232,7 +232,7 @@ open_restricted(const char *path, int flags, void *user_data)
- if (fd < 0)
- fprintf(stderr, "Failed to open %s (%s)\n",
- path, strerror(errno));
-- else if (*grab && ioctl(fd, EVIOCGRAB, (void*)1) == -1)
-+ else if (grab && *grab && ioctl(fd, EVIOCGRAB, (void*)1) == -1)
- fprintf(stderr, "Grab requested, but failed for %s (%s)\n",
- path, strerror(errno));
-
---
-2.18.0
-
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
index fcc02bdd4e..74384667ca 100644
--- a/main/libinput/APKBUILD
+++ b/main/libinput/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=libinput
-pkgver=1.11.1
-pkgrel=1
+pkgver=1.11.2
+pkgrel=0
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput"
arch="all"
@@ -10,8 +10,7 @@ license="MIT"
makedepends="eudev-dev libevdev-dev meson mtdev-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
options="!check"
-source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
- 0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch"
+source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -29,5 +28,4 @@ package() {
DESTDIR="$pkgdir" ninja -C builddir/ install
}
-sha512sums="3dd1a318c89d66f5a66016c6dbfa5277b61a8cb5337d99f85b1eeef40ed894bdc04fd4588a97383988daea0f034df5a72bff318325320a01b857db9deb94a2b0 libinput-1.11.1.tar.xz
-52a897a0c974d0c5a205215505024550f0863c92cb456d99085d28f39f2744a6a5c2968a7f6ea7a19ba6e74e24a42b6e51172a9276e8e1c75e9f7b4006571e55 0001-tools-pass-a-valid-grab-parameter-to-list-devices.patch"
+sha512sums="cb6ada877fc3c09f634f3db39d5507e66d4b86c3d632bb8f7498c7b01fdf8372b2053a79b641293900b7fcc0aa4e920f7c830d9c7b2d9ff3cd61c58eb7c20b65 libinput-1.11.2.tar.xz"