aboutsummaryrefslogtreecommitdiffstats
path: root/main/libmad
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 22:39:50 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:32:54 +0000
commitdda2c5c88b8f16892f5b554ffa192025e24b843b (patch)
tree23d9c77ad6181e337de7b100abcf1480e0cf0cfd /main/libmad
parent3588dc7e623cb28ca8c54ce5bd293b9a82f012c1 (diff)
downloadaports-dda2c5c88b8f16892f5b554ffa192025e24b843b.tar.bz2
aports-dda2c5c88b8f16892f5b554ffa192025e24b843b.tar.xz
main/libmad: modernise, mark no tests, fix license
Diffstat (limited to 'main/libmad')
-rw-r--r--main/libmad/APKBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/main/libmad/APKBUILD b/main/libmad/APKBUILD
index d542c5bc33..ef2cd3e951 100644
--- a/main/libmad/APKBUILD
+++ b/main/libmad/APKBUILD
@@ -2,11 +2,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmad
pkgver=0.15.1b
-pkgrel=7
+pkgrel=8
pkgdesc="A high-quality MPEG audio decoder"
url="http://www.underbit.com/products/mad/"
arch="all"
-license="GPL"
+options="!check" # No test suite.
+license="GPL-2.0+"
subpackages="$pkgname-dev"
depends=
makedepends="autoconf automake libtool"
@@ -17,34 +18,28 @@ source="http://downloads.sourceforge.net/sourceforge/mad/$pkgname-$pkgver.tar.gz
mad.pc
"
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ update_config_sub
+ default_prepare
libtoolize --force && aclocal -I m4 && autoconf \
- && automake --add-missing --foreign || return 1
+ && automake --add-missing --foreign
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --enable-accuracy \
- || return 1
+ --enable-accuracy
- make -j1 || return 1
+ make -j1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -D -m644 "$srcdir"/mad.pc "$pkgdir"/usr/lib/pkgconfig/mad.pc
}
sha512sums="2cad30347fb310dc605c46bacd9da117f447a5cabedd8fefdb24ab5de641429e5ec5ce8af7aefa6a75a3f545d3adfa255e3fa0a2d50971f76bc0c4fc0400cc45 libmad-0.15.1b.tar.gz