aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnetfilter_log
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-29 08:01:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-29 08:44:18 +0000
commit04a14ba885aaaa8f281bfdaf663510375c66d346 (patch)
treecb3b7137034aa5bb4c4d67d8509f88e5528ec1cb /main/libnetfilter_log
parent95ad883e6da70d2e773b489f1c316bfcb21d993f (diff)
downloadaports-04a14ba885aaaa8f281bfdaf663510375c66d346.tar.bz2
aports-04a14ba885aaaa8f281bfdaf663510375c66d346.tar.xz
main/libnetfilter_log: pull in sys/types.h for int types
This actually requires _GNU_SOURCE
Diffstat (limited to 'main/libnetfilter_log')
-rw-r--r--main/libnetfilter_log/APKBUILD22
-rw-r--r--main/libnetfilter_log/sys-types.patch21
-rw-r--r--main/libnetfilter_log/sys-types2.patch14
3 files changed, 54 insertions, 3 deletions
diff --git a/main/libnetfilter_log/APKBUILD b/main/libnetfilter_log/APKBUILD
index 33f1d47261..1bc010c9f6 100644
--- a/main/libnetfilter_log/APKBUILD
+++ b/main/libnetfilter_log/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=libnetfilter_log
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="interface to packets that have been logged by the kernel packet filter"
url="http://www.netfilter.org/projects/libnetfilter_log/"
arch="all"
@@ -12,13 +12,21 @@ depends=
depends_dev="linux-headers"
makedepends="$depends_dev libnfnetlink-dev"
subpackages="$pkgname-dev"
-source="http://www.netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2"
+source="http://www.netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2
+ sys-types.patch
+ sys-types2.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -40,4 +48,12 @@ package() {
rm "$pkgdir"/usr/lib/*.la || return 1
}
-md5sums="2a4bb0654ae675a52d2e8d1c06090b94 libnetfilter_log-1.0.1.tar.bz2"
+md5sums="2a4bb0654ae675a52d2e8d1c06090b94 libnetfilter_log-1.0.1.tar.bz2
+4a3b135f683291a9444082b151485591 sys-types.patch
+210445355fc1ff63d6558e8d643edfcc sys-types2.patch"
+sha256sums="74e0fe75753dba3ac114531b5e73240452c789a3f3adccf5c51217da1d933b21 libnetfilter_log-1.0.1.tar.bz2
+0adb7b8e3b68621de8809f56d811f7fa0276f468fa4c3cb501eb7dd9faf80182 sys-types.patch
+b78bc2ad8352bb2f925d41eb0c440bf6b4ef83a912f7ff07d44e30275e105042 sys-types2.patch"
+sha512sums="4088b9bf055fb4cd5f2e201a46a00def7642116b5d1695a371936b7b45eb93877944456506b45761bf2f3f81b40c161c1ecdcfb90532009f073dac3cedc6f436 libnetfilter_log-1.0.1.tar.bz2
+aa8b2502fd53bce2ffdb4607bcbb179b854d9544814eca43c5313392c39bf5f8abdc51e61629d26cce1df07b0499d793858020144eac6d4785ab96d59db8e364 sys-types.patch
+b2c93fc854cd52040637164f422ac9bc6cdf22585c638b45f500c30c59925131ff874fdf3dc231d948adf12b45744809d6278a79abd4a2887aa5a7b5e8e4cc9d sys-types2.patch"
diff --git a/main/libnetfilter_log/sys-types.patch b/main/libnetfilter_log/sys-types.patch
new file mode 100644
index 0000000000..1662636cc6
--- /dev/null
+++ b/main/libnetfilter_log/sys-types.patch
@@ -0,0 +1,21 @@
+From 7529487f70e244cd31ef84b037b1c32749c134a7 Mon Sep 17 00:00:00 2001
+From: Eric Leblond <eric@regit.org>
+Date: Sun, 4 Nov 2012 09:29:44 +0100
+Subject: Add include needed for integer type definition.
+
+
+diff --git a/include/libnetfilter_log/libnetfilter_log.h b/include/libnetfilter_log/libnetfilter_log.h
+index 6b0d3b0..a1331de 100644
+--- a/include/libnetfilter_log/libnetfilter_log.h
++++ b/include/libnetfilter_log/libnetfilter_log.h
+@@ -9,6 +9,7 @@
+ #ifndef __LIBNETFILTER_LOG_H
+ #define __LIBNETFILTER_LOG_H
+
++#include <sys/types.h>
+ #include <libnetfilter_log/linux_nfnetlink_log.h>
+
+ struct nflog_handle;
+--
+cgit v0.10.2
+
diff --git a/main/libnetfilter_log/sys-types2.patch b/main/libnetfilter_log/sys-types2.patch
new file mode 100644
index 0000000000..e211453ecf
--- /dev/null
+++ b/main/libnetfilter_log/sys-types2.patch
@@ -0,0 +1,14 @@
+diff --git a/include/libnetfilter_log/libipulog.h b/include/libnetfilter_log/libipulog.h
+index 8a4ae2a..0994b4a 100644
+--- a/include/libnetfilter_log/libipulog.h
++++ b/include/libnetfilter_log/libipulog.h
+@@ -5,6 +5,8 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+
++#include <sys/types.h> /* for u_int*_t */
++
+ /* FIXME: glibc sucks */
+ #ifndef MSG_TRUNC
+ #define MSG_TRUNC 0x20
+