aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnftnl
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2015-09-15 15:42:02 +0000
committerEivind Uggedal <eivind@uggedal.com>2015-09-15 15:42:02 +0000
commit2a866db42b298ebc0b7d3b5640619e9788d4d135 (patch)
tree6fa92b112d0659c846530618eba36843500e9e48 /main/libnftnl
parent9059f7019a2677e3521aec7c889624a2ae0e5759 (diff)
downloadaports-2a866db42b298ebc0b7d3b5640619e9788d4d135.tar.bz2
aports-2a866db42b298ebc0b7d3b5640619e9788d4d135.tar.xz
main/libnftnl: moved from testing
Diffstat (limited to 'main/libnftnl')
-rw-r--r--main/libnftnl/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/libnftnl/APKBUILD b/main/libnftnl/APKBUILD
new file mode 100644
index 0000000000..50e7c6b139
--- /dev/null
+++ b/main/libnftnl/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=libnftnl
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
+url="http://netfilter.org/projects/libnftnl/"
+arch="all"
+license="GPL-2"
+depends=""
+depends_dev="libmnl-dev"
+makedepends="$depends_dev bash"
+install=""
+subpackages="$pkgname-dev $pkgname-libs"
+source="http://netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="203701a73cc3c51ca751d7cb2e176250 libnftnl-1.0.3.tar.bz2"
+sha256sums="cf0ae7eab6a6866192a1fbd6b370a8a2cbe2066fe3975ab44939fd50747c27f7 libnftnl-1.0.3.tar.bz2"
+sha512sums="6fba3f3a0c3d98e0c3200edbd45910e326f0864383dc695fa77580d47d3fe541c50518f62d2dbfc50b2378b9b311aec28b3321ef18f59a321e0a3f0817952181 libnftnl-1.0.3.tar.bz2"