aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnftnl
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-05 20:11:52 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-05 20:11:52 +0100
commit2c612b146af42c6c9b67054851e2e064740e4c31 (patch)
tree2011818bd5a625ac6eb82009a600ef9aa877b32c /main/libnftnl
parent84bdfa76141d469138f25b98c10cc2ef6e12abf7 (diff)
downloadaports-2c612b146af42c6c9b67054851e2e064740e4c31.tar.bz2
aports-2c612b146af42c6c9b67054851e2e064740e4c31.tar.xz
main/libnftnl: add check
To make the entire test suite pass we also need to enable json parsing (--with-json-parsing).
Diffstat (limited to 'main/libnftnl')
-rw-r--r--main/libnftnl/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/libnftnl/APKBUILD b/main/libnftnl/APKBUILD
index 1b38aa5edf..c3e25c0afa 100644
--- a/main/libnftnl/APKBUILD
+++ b/main/libnftnl/APKBUILD
@@ -2,30 +2,36 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=libnftnl
pkgver=1.0.8
-pkgrel=0
+pkgrel=1
pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
url="http://netfilter.org/projects/libnftnl/"
arch="all"
license="GPL2"
depends_dev="libmnl-dev"
-makedepends="$depends_dev bash"
+makedepends="$depends_dev bash jansson-dev"
subpackages="$pkgname-dev $pkgname-libs"
source="http://netfilter.org/projects/$pkgname/files/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --with-json-parsing
make
}
+check() {
+ cd "$builddir"/tests
+ make check # builds test binaries
+ ./test-script.sh
+}
+
package() {
make DESTDIR="$pkgdir" -C "$builddir" install
}