aboutsummaryrefslogtreecommitdiffstats
path: root/main/libotr
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /main/libotr
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'main/libotr')
-rw-r--r--main/libotr/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/main/libotr/APKBUILD b/main/libotr/APKBUILD
index 3c9b927d18..75930207f2 100644
--- a/main/libotr/APKBUILD
+++ b/main/libotr/APKBUILD
@@ -4,38 +4,36 @@ pkgname=libotr
pkgver=4.1.1
pkgrel=1
pkgdesc="Off The Record Messaging, an encryption library for secure IM conversations"
+options="!check"
url="http://otr.cypherpunks.ca/"
arch="all"
license="LGPL-2.0-or-later"
-depends=
depends_dev="libgcrypt-dev"
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://www.cypherpunks.ca/otr/libotr-$pkgver.tar.gz"
-builddir="$srcdir/libotr-$pkgver"
+prepare() {
+ default_prepare
+ update_config_sub
+}
build() {
- cd "$builddir"
- update_config_sub || return 1
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
tools() {
pkgdesc="$pkgname tools"
mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/ || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
sha512sums="c957206235b9f627542f23a645c822ea1b318d83fa655f41ed8d9a3c0dddf30b88f0ca82060026af155e48ecb13969dc9270831f20304669794151f666ae5cb0 libotr-4.1.1.tar.gz"