aboutsummaryrefslogtreecommitdiffstats
path: root/main/libotr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-14 12:55:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-14 12:55:24 +0000
commitabb314d550cd23f6ad4a8625e0e0b3865fdb9642 (patch)
tree85fdfd72b9d52fc856441e758c53eee7b1f7135d /main/libotr
parent8260478bd02cc1b13104dcc71ea8618afdcb14a1 (diff)
downloadaports-abb314d550cd23f6ad4a8625e0e0b3865fdb9642.tar.bz2
aports-abb314d550cd23f6ad4a8625e0e0b3865fdb9642.tar.xz
main/libotr: upgrade to 4.0.0
Diffstat (limited to 'main/libotr')
-rw-r--r--main/libotr/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/main/libotr/APKBUILD b/main/libotr/APKBUILD
new file mode 100644
index 0000000000..1150e948c7
--- /dev/null
+++ b/main/libotr/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=libotr
+pkgver=4.0.0
+pkgrel=0
+pkgdesc="Off The Record Messaging, an encryption library for secure IM conversations"
+url="http://otr.cypherpunks.ca/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="libgcrypt-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc:doc $pkgname-tools:tools"
+source="http://www.cypherpunks.ca/otr/libotr-$pkgver.tar.gz"
+
+_builddir="$srcdir/libotr-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+tools() {
+ license="GPL"
+ depends="$pkgname"
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+doc() {
+ depends="$pkgname"
+ cd "$_builddir"
+ install -Dm0644 Protocol-v2.html "$subpkgdir"/usr/share/doc/$pkgname/Protocol-v2.html
+ install -Dm0644 README "$subpkgdir"/usr/share/doc/$pkgname/README
+}
+
+md5sums="00979dca82d70383fcd1b01f3974363c libotr-4.0.0.tar.gz"
+sha256sums="3f911994409898e74527730745ef35ed75c352c695a1822a677a34b2cf0293b4 libotr-4.0.0.tar.gz"
+sha512sums="3f0a549bb615d6ff486db0efcc82fc6ad17c5860740c760315d5c81d298b00648d11f9da69c65b9859111d2150e4d10062aeb8611810f11e1da1ce62f07f02b6 libotr-4.0.0.tar.gz"