aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpcap
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-27 10:05:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-27 10:05:11 +0000
commit907e7dba15ae3274c3a082b0eec26e162d46844f (patch)
treea51b37e256695383903b6f206ba85a2fda4188fa /main/libpcap
parentc404c4130cb25c80ffe3c581bf814cb110c5a0ac (diff)
downloadaports-907e7dba15ae3274c3a082b0eec26e162d46844f.tar.bz2
aports-907e7dba15ae3274c3a082b0eec26e162d46844f.tar.xz
main/libpcap: build fix
include limits.h for PATH_MAX. Fixes build on ppc64le
Diffstat (limited to 'main/libpcap')
-rw-r--r--main/libpcap/APKBUILD8
-rw-r--r--main/libpcap/fix-headers.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/main/libpcap/APKBUILD b/main/libpcap/APKBUILD
index a3116d11d1..94c4cdba2b 100644
--- a/main/libpcap/APKBUILD
+++ b/main/libpcap/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpcap
pkgver=1.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="A system-independent interface for user-level packet capture"
url="http://www.tcpdump.org/"
arch="all"
@@ -9,7 +9,8 @@ license="BSD"
depends=
options="!check"
makedepends="bison flex autoconf linux-headers"
-source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz"
+source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz
+ fix-headers.patch"
subpackages="$pkgname-doc $pkgname-dev"
builddir="$srcdir"/$pkgname-$pkgver
@@ -36,4 +37,5 @@ package() {
make -j1 DESTDIR="$pkgdir" install install-shared
}
-sha512sums="0ff25641f1e9d29082766caef45888c19214f770c4f378818caa73fcbc4ae54ad9195549c2499d4879ff46e35741d93b2b02cc5f3d6aa99e85a32194cf10bfe7 libpcap-1.9.0.tar.gz"
+sha512sums="0ff25641f1e9d29082766caef45888c19214f770c4f378818caa73fcbc4ae54ad9195549c2499d4879ff46e35741d93b2b02cc5f3d6aa99e85a32194cf10bfe7 libpcap-1.9.0.tar.gz
+77590c8fcea96427fd08e85023609695f8b280a9b24a503d19b08a3c6baf3537a949c94078a5cd577f0476d735a257050955590374d85ce6a2f35a09143da5a3 fix-headers.patch"
diff --git a/main/libpcap/fix-headers.patch b/main/libpcap/fix-headers.patch
new file mode 100644
index 0000000000..5b24e0ac54
--- /dev/null
+++ b/main/libpcap/fix-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/pcap-usb-linux.c b/pcap-usb-linux.c
+index 6f8adf6..82780fa 100644
+--- a/pcap-usb-linux.c
++++ b/pcap-usb-linux.c
+@@ -57,6 +57,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+ #include <sys/utsname.h>
++#include <limits.h>
+ #ifdef HAVE_LINUX_USBDEVICE_FS_H
+ /*
+ * We might need <linux/compiler.h> to define __user for