aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 23:30:31 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 18:07:29 +0000
commit156291d817c946e617d707a69974dd6b214516a4 (patch)
tree6b28e720b12811c5145d0d323d0cfbfc9ac906fb /main/libpthread-stubs
parent9c63848b584bab4478e05725b9880a01d8ca38e4 (diff)
downloadaports-156291d817c946e617d707a69974dd6b214516a4.tar.bz2
aports-156291d817c946e617d707a69974dd6b214516a4.tar.xz
main/libpthread-stubs: add check
Diffstat (limited to 'main/libpthread-stubs')
-rw-r--r--main/libpthread-stubs/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index 1221e3c551..8cb7f2856c 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpthread-stubs
pkgver=0.3
-pkgrel=4
+pkgrel=5
pkgdesc="Pthread functions stubs for platforms missing them"
url="https://cgit.freedesktop.org/xcb/pthread-stubs"
arch="all"
@@ -26,6 +26,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" install