aboutsummaryrefslogtreecommitdiffstats
path: root/main/librelp
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-27 19:55:23 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-28 01:51:37 +0100
commit8190aae00739bc46d5ee8a804d3c96cb24e9e540 (patch)
tree3a54bc00138a58c748de7d308c86610360090ffc /main/librelp
parentc24314f73b7bb44a6d16b359ecb62050703c917d (diff)
downloadaports-8190aae00739bc46d5ee8a804d3c96cb24e9e540.tar.bz2
aports-8190aae00739bc46d5ee8a804d3c96cb24e9e540.tar.xz
main/librelp: new aport (needed for main/rsyslog)
The Reliable Event Logging Protocol library https://www.rsyslog.org
Diffstat (limited to 'main/librelp')
-rw-r--r--main/librelp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/librelp/APKBUILD b/main/librelp/APKBUILD
new file mode 100644
index 0000000000..de86652fa8
--- /dev/null
+++ b/main/librelp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=librelp
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="The Reliable Event Logging Protocol library"
+url="https://www.rsyslog.com"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gnutls-dev"
+subpackages="$pkgname-dev"
+source="http://download.rsyslog.com/librelp/$pkgname-$pkgver.tar.gz"
+options="!check" # XXX: all tests fail, don't know why
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6e60398c68a78f4b4202a697e144f1516ff3bbb32192f745b52c77d107954febf8cb31d2e166efa96c00122f6807860ecd01084f1d3d4005336f2cb75e6461c9 librelp-1.3.0.tar.gz"