aboutsummaryrefslogtreecommitdiffstats
path: root/main/libressl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-26 13:37:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:28:14 +0000
commitc2122a25c7bd984ed8efbc27c224481d91567b21 (patch)
treeee30bcd9a31a2f5873e043f63c4a545478038a7e /main/libressl
parent155dac8b94faa2db7204d7330872b85dfc8bb3bf (diff)
downloadaports-c2122a25c7bd984ed8efbc27c224481d91567b21.tar.bz2
aports-c2122a25c7bd984ed8efbc27c224481d91567b21.tar.xz
main/libressl: let openssl replace
Diffstat (limited to 'main/libressl')
-rw-r--r--main/libressl/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 1663ed3e99..3d1fa7e7b4 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -12,7 +12,7 @@
pkgname=libressl
pkgver=2.7.4
_namever=${pkgname}${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
@@ -21,7 +21,6 @@ depends=""
makedepends_build="automake autoconf libtool"
makedepends_host="linux-headers"
makedepends="$makedepends_host $makedepends_build"
-replaces="openssl openssl1.0"
subpackages="$pkgname-dbg $_namever-libcrypto:_libs $_namever-libssl:_libs
$_namever-libtls:_libs $pkgname-dev $pkgname-doc"
source="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz
@@ -63,11 +62,12 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
-}
-dev() {
- default_dev
- replaces="openssl1.0-dev"
+ # /usr/bin/openssl will be replaced with openssl's binary. We provide
+ # a /usr/bin/libressl binary in case something needs it and a
+ # symlink so /usr/bin/openssl exists during upgrade
+ mv "$pkgdir"/usr/bin/openssl "$pkgdir"/usr/bin/libressl
+ ln -s libressl "$pkgdir"/usr/bin/openssl
}
_libs() {