aboutsummaryrefslogtreecommitdiffstats
path: root/main/librsync
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-18 22:51:16 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-23 06:59:28 +0000
commit37efd4ece41892564b5e2ce839fba7c82a1d2b87 (patch)
treeb84ae45a9573fa5e9790bbdff533e8520b09addf /main/librsync
parentf8720ebf96b5ad742ecd4ee8d40a27ab7b146840 (diff)
downloadaports-37efd4ece41892564b5e2ce839fba7c82a1d2b87.tar.bz2
aports-37efd4ece41892564b5e2ce839fba7c82a1d2b87.tar.xz
main/librsync: clarify license, run test suite
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'main/librsync')
-rw-r--r--main/librsync/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/main/librsync/APKBUILD b/main/librsync/APKBUILD
index 5c2087c395..67218058d8 100644
--- a/main/librsync/APKBUILD
+++ b/main/librsync/APKBUILD
@@ -6,12 +6,18 @@ pkgrel=0
pkgdesc="librsync implements the rolling-checksum algorithm of rsync"
url="https://github.com/librsync/librsync"
arch="all"
-license="LGPL-2.1"
+license="LGPL-2.1-or-later"
makedepends="cmake popt-dev bzip2-dev zlib-dev perl"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ # don't invoke bash in test scripts
+ sed -i 's,#! /bin/bash,#!/bin/sh,' tests/rdiff_bad_option.sh
+}
+
build() {
cd "$builddir"
cmake \
@@ -23,6 +29,10 @@ build() {
}
+check() {
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install