aboutsummaryrefslogtreecommitdiffstats
path: root/main/librsync
diff options
context:
space:
mode:
authorJeremy Thomerson <jeremy@thomersonfamily.com>2011-03-26 22:40:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-27 13:27:01 +0000
commita948ff23afdfea6b407f71a7764e5abb26d34c21 (patch)
treefaab5e1349bcafadb746af11ecc77396822eacc7 /main/librsync
parentc4c9fd3a4232584fffbe386e7fc4c98dfb3534b4 (diff)
downloadaports-a948ff23afdfea6b407f71a7764e5abb26d34c21.tar.bz2
aports-a948ff23afdfea6b407f71a7764e5abb26d34c21.tar.xz
main/librsync: move from testing
Diffstat (limited to 'main/librsync')
-rw-r--r--main/librsync/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/librsync/APKBUILD b/main/librsync/APKBUILD
new file mode 100644
index 0000000000..248cda5c90
--- /dev/null
+++ b/main/librsync/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
+pkgname=librsync
+pkgver=0.9.7
+pkgrel=0
+pkgdesc="librsync implements the rolling-checksum algorithm of rsync"
+url="http://sourceforge.net/projects/librsync/"
+arch="all"
+license="LGPL 2.1"
+depends=""
+makedepends=""
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="24cdb6b78f45e0e83766903fd4f6bc84 librsync-0.9.7.tar.gz"