aboutsummaryrefslogtreecommitdiffstats
path: root/main/libseccomp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-03-29 12:23:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-29 12:23:59 +0000
commitf84859a2fe68052458305723d28cda031813ac6d (patch)
tree48932d939cb2c8a1b144ea0c15ba6b5efff9e51b /main/libseccomp
parentde922e5ed21b547ce3eaed5400941515be8dd8f0 (diff)
downloadaports-f84859a2fe68052458305723d28cda031813ac6d.tar.bz2
aports-f84859a2fe68052458305723d28cda031813ac6d.tar.xz
main/libseccomp: move from testing
requested by docker inc.
Diffstat (limited to 'main/libseccomp')
-rw-r--r--main/libseccomp/APKBUILD53
-rw-r--r--main/libseccomp/remove-redefinition-prctl.patch10
2 files changed, 63 insertions, 0 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
new file mode 100644
index 0000000000..c889f5406d
--- /dev/null
+++ b/main/libseccomp/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=libseccomp
+pkgver=2.3.0
+pkgrel=0
+pkgdesc="An interface to the Linux Kernel's syscall filtering mechanismf"
+url="https://github.com/seccomp/libseccomp"
+arch="all"
+license="LGPLv2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
+ remove-redefinition-prctl.patch"
+
+_builddir="$srcdir"/libseccomp-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f93b366adc6a0dc94c37002b3ead67d1 libseccomp-2.3.0.tar.gz
+f10f467d772d6fcfbfb05e3bbba450b4 remove-redefinition-prctl.patch"
+sha256sums="d756e3a77578259a808698a50c43d44612aae3339ea42ab5b15ea983f26b901d libseccomp-2.3.0.tar.gz
+e133750447fcf0f84504d7dff4a915e357cfce9961576c57fe63df669f8dc58a remove-redefinition-prctl.patch"
+sha512sums="398643af0920ff446b37a74e48f7a96ad2bec4f514e92fc6f8242b7515dcb8f5d06c2894790b22f62387c2d9b75efd54a4d5944f973239a05f06ec840f2a5a0b libseccomp-2.3.0.tar.gz
+f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"
diff --git a/main/libseccomp/remove-redefinition-prctl.patch b/main/libseccomp/remove-redefinition-prctl.patch
new file mode 100644
index 0000000000..2ea88fe057
--- /dev/null
+++ b/main/libseccomp/remove-redefinition-prctl.patch
@@ -0,0 +1,10 @@
+--- ./src/system.c.orig
++++ ./src/system.c
+@@ -21,7 +21,6 @@
+
+ #include <stdlib.h>
+ #include <errno.h>
+-#include <sys/prctl.h>
+
+ #include <seccomp.h>
+