aboutsummaryrefslogtreecommitdiffstats
path: root/main/libssh/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /main/libssh/APKBUILD
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'main/libssh/APKBUILD')
-rw-r--r--main/libssh/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/main/libssh/APKBUILD b/main/libssh/APKBUILD
deleted file mode 100644
index bca16969b5..0000000000
--- a/main/libssh/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=libssh
-pkgver=0.9.3
-pkgrel=1
-pkgdesc="Library for accessing ssh client services through C libraries"
-url="https://www.libssh.org/"
-arch="all"
-license="LGPL-2.1-or-later BSD-2-Clause"
-depends_dev="openssl-dev zlib-dev"
-makedepends="$depends_dev cmake doxygen"
-checkdepends="cmocka-dev"
-subpackages="$pkgname-dev"
-source="https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz
- "
-
-# secfixes:
-# 0.9.3-r0:
-# - CVE-2019-14889
-# 0.7.6-r0:
-# - CVE-2018-10933
-
-build() {
- mkdir build && cd build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DWITH_GSSAPI=OFF \
- -DUNIT_TESTING=ON
- make
-}
-
-check() {
- case "$CARCH" in
- s390x) _disabled_tests="-E torture_threads_buffer"
- esac
- cd "$builddir/build"
- ctest --output-on-failure $_disabled_tests
-}
-
-package() {
- cd "$builddir/build"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="6e59718565daeca6d224426cc1095a112deff9af8e0b021917e04f08bb7409263c35724de95f591f38e26f0fb3bbbbc69b679b6775edc21dec158d241b076c6f libssh-0.9.3.tar.xz"