aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtirpc
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-03-24 16:14:52 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-04-27 06:02:09 +0000
commit9edb53cea056101c4963a04b747bf102de23f919 (patch)
tree6dee594aa149695703e18019b0574d2a98220c36 /main/libtirpc
parent49bcf5321eafe880f4e40ad50a0647562ffdf5bb (diff)
downloadaports-9edb53cea056101c4963a04b747bf102de23f919.tar.bz2
aports-9edb53cea056101c4963a04b747bf102de23f919.tar.xz
main/libtirpc: fix exported symbols map
fixes #7041
Diffstat (limited to 'main/libtirpc')
-rw-r--r--main/libtirpc/APKBUILD27
-rw-r--r--main/libtirpc/exports.patch11
-rw-r--r--main/libtirpc/yp.patch13
3 files changed, 18 insertions, 33 deletions
diff --git a/main/libtirpc/APKBUILD b/main/libtirpc/APKBUILD
index 563ccde065..03e011a138 100644
--- a/main/libtirpc/APKBUILD
+++ b/main/libtirpc/APKBUILD
@@ -1,34 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtirpc
pkgver=1.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
url="http://libtirpc.sourceforge.net/"
arch="all"
license="BSD"
+options="!check"
depends=
depends_dev="krb5-dev bsd-compat-headers"
makedepends="$depends_dev autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ exports.patch
git.patch
"
-
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -N -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
- autoreconf -vif || return 1
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,13 +29,10 @@ build() {
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="36ce1c0ff80863bb0839d54aa0b94014 libtirpc-1.0.1.tar.bz2
-43be5566ae65d498938688a713472193 git.patch"
-sha256sums="5156974f31be7ccbc8ab1de37c4739af6d9d42c87b1d5caf4835dda75fcbb89e libtirpc-1.0.1.tar.bz2
-0a62de190d38660efff0ddbb73b5b6315fdc015c20cf9c235e35c0cf7eeb0e85 git.patch"
sha512sums="c9b449e737bc2bd3d56e31e8352f312e89a7ec2a11b73b5ac314e7d82d3b644c611e422b623912453b67b668f86a6de7bb7f18c9495dd15de8e2798ec2ff41c8 libtirpc-1.0.1.tar.bz2
+b0620c54f673d130d7f2eb6cd41c618a6ef0eeaa3450575f507800d64a276ed1dc8d5c7b831d6cbd929ab199264339cc09f6a4fcb011e457e06bdd849645c6e2 exports.patch
4dd540470e9a25b5df0ea2c883dd647f26b71ed82e880c7efa4eed51dd98b898e18964a3ee998ceeadf39caed0a661f110f72157ec70584e33131d0a0f375a00 git.patch"
diff --git a/main/libtirpc/exports.patch b/main/libtirpc/exports.patch
new file mode 100644
index 0000000000..c50a23df72
--- /dev/null
+++ b/main/libtirpc/exports.patch
@@ -0,0 +1,11 @@
+--- a/src/libtirpc.map
++++ b/src/libtirpc.map
+@@ -298,7 +298,7 @@
+ key_gendes;
+ key_get_conv;
+ key_setsecret;
+- key_secret_is_set;
++ key_secretkey_is_set;
+ key_setnet;
+ netname2host;
+ netname2user;
diff --git a/main/libtirpc/yp.patch b/main/libtirpc/yp.patch
deleted file mode 100644
index dd32219254..0000000000
--- a/main/libtirpc/yp.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/getpublickey.c.orig
-+++ ./src/getpublickey.c
-@@ -38,8 +38,10 @@
- #include <pwd.h>
- #include <rpc/rpc.h>
- #include <rpc/key_prot.h>
-+#ifdef YP
- #include <rpcsvc/yp_prot.h>
- #include <rpcsvc/ypclnt.h>
-+#endif
- #include <string.h>
- #include <stdlib.h>
-