aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtorrent
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-07 10:30:13 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-09 09:08:06 +0200
commit3bdcca3c8322a57ee6de2abf417199f496d990fd (patch)
tree52dc0f92105dfb2bcc7ab2d7f0815edc6a48b3ae /main/libtorrent
parent90787199613290fdcbfef3365f98b3a4e9855c10 (diff)
downloadaports-3bdcca3c8322a57ee6de2abf417199f496d990fd.tar.bz2
aports-3bdcca3c8322a57ee6de2abf417199f496d990fd.tar.xz
main/libtorrent: moved from testing
Diffstat (limited to 'main/libtorrent')
-rw-r--r--main/libtorrent/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/libtorrent/APKBUILD b/main/libtorrent/APKBUILD
new file mode 100644
index 0000000000..ec51d9046b
--- /dev/null
+++ b/main/libtorrent/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=libtorrent
+pkgver=0.13.2
+pkgrel=0
+pkgdesc='BitTorrent library written in C++'
+url='http://libtorrent.rakshasa.no/'
+arch='all'
+license='GPL'
+makedepends='libsigc++-dev openssl-dev'
+subpackages="$pkgname-dev"
+options='libtool'
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="96c0b81501357df402ab592f59ecaeab libtorrent-0.13.2.tar.gz"