aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtorrent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-30 08:51:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-07-30 08:54:53 +0000
commit5c904717322f8113870abf48cc93c3c8b00ab4e8 (patch)
treee077e5c3afa20630fd6e96db5872f03d622d639e /main/libtorrent
parenta879839450737e3cbdb64415af42347c97ccfa28 (diff)
downloadaports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.bz2
aports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.xz
[all autotools packages]: normalize ./configure
Diffstat (limited to 'main/libtorrent')
-rw-r--r--main/libtorrent/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/main/libtorrent/APKBUILD b/main/libtorrent/APKBUILD
index 2f23d1f53b..d7d0dad963 100644
--- a/main/libtorrent/APKBUILD
+++ b/main/libtorrent/APKBUILD
@@ -13,19 +13,20 @@ options='libtool'
source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
- ./configure \
- --prefix=/usr \
- --disable-debug \
- || return 1
-
- make || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+ make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
}
md5sums="e94f6c590bb02aaf4d58618f738a85f2 libtorrent-0.13.3.tar.gz"