aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtorrent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 16:03:35 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 16:03:35 +0000
commitf6723fe78a8b7ad141c619908bcd809abe43b78d (patch)
tree109de25c6ec5f7695e45255ad6d8d6f5e203ef86 /main/libtorrent
parentcde4c288fb31f74d2401cef0558ab3c56ada33ca (diff)
downloadaports-f6723fe78a8b7ad141c619908bcd809abe43b78d.tar.bz2
aports-f6723fe78a8b7ad141c619908bcd809abe43b78d.tar.xz
main/[various]: update config.sub
Diffstat (limited to 'main/libtorrent')
-rw-r--r--main/libtorrent/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/libtorrent/APKBUILD b/main/libtorrent/APKBUILD
index d7d0dad963..b938de68e0 100644
--- a/main/libtorrent/APKBUILD
+++ b/main/libtorrent/APKBUILD
@@ -12,8 +12,15 @@ subpackages="$pkgname-dev"
options='libtool'
source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -25,7 +32,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}