aboutsummaryrefslogtreecommitdiffstats
path: root/main/libuv
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-20 13:53:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-20 13:56:06 +0000
commit3ff03cdeca8eac2243f0077ca8a5ff78540558f0 (patch)
tree727db9001c75d372867178b019e9df96ccf430fb /main/libuv
parentf3fd88b88366b0d50635497bd1dee792223b34f7 (diff)
downloadaports-3ff03cdeca8eac2243f0077ca8a5ff78540558f0.tar.bz2
aports-3ff03cdeca8eac2243f0077ca8a5ff78540558f0.tar.xz
main/libuv: disable setuid/getuid tests
the fail in fakeroot
Diffstat (limited to 'main/libuv')
-rw-r--r--main/libuv/APKBUILD7
-rw-r--r--main/libuv/disable-setuid-test.patch46
2 files changed, 51 insertions, 2 deletions
diff --git a/main/libuv/APKBUILD b/main/libuv/APKBUILD
index a99fb66324..8746991409 100644
--- a/main/libuv/APKBUILD
+++ b/main/libuv/APKBUILD
@@ -10,7 +10,9 @@ arch="all"
license="MIT BSD ISC"
makedepends="automake autoconf libtool linux-headers"
subpackages="$pkgname-dev $pkgname-dbg"
-source="http://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz"
+source="http://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz
+ disable-setuid-test.patch
+ "
builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
@@ -45,4 +47,5 @@ check() {
make check || return 1
}
-sha512sums="5b56e4c337093c6ddc12f8353b011fba9e57fd84565e279bfc13a7d16d3b6dc01f02fee52a32f38ef630a0f5200fc63f3cc04137af21942422c3dcf535212f02 libuv-v1.11.0.tar.gz"
+sha512sums="5b56e4c337093c6ddc12f8353b011fba9e57fd84565e279bfc13a7d16d3b6dc01f02fee52a32f38ef630a0f5200fc63f3cc04137af21942422c3dcf535212f02 libuv-v1.11.0.tar.gz
+478d25c8905cd393b9ced0f1b16e70794a7ef20fb9eb212fd74e50beca3f5a33a6a5267616abecf470426ed3d00efec51df468745ff43c0de05c0ad8234f1eb3 disable-setuid-test.patch"
diff --git a/main/libuv/disable-setuid-test.patch b/main/libuv/disable-setuid-test.patch
new file mode 100644
index 0000000000..3c6e016113
--- /dev/null
+++ b/main/libuv/disable-setuid-test.patch
@@ -0,0 +1,46 @@
+diff --git a/test/test-list.h b/test/test-list.h
+index 3a1e82a..dd25e69 100644
+--- a/test/test-list.h
++++ b/test/test-list.h
+@@ -240,8 +240,10 @@ TEST_DECLARE (spawn_detached)
+ TEST_DECLARE (spawn_and_kill_with_std)
+ TEST_DECLARE (spawn_and_ping)
+ TEST_DECLARE (spawn_preserve_env)
++#if 0
+ TEST_DECLARE (spawn_setuid_fails)
+ TEST_DECLARE (spawn_setgid_fails)
++#endif
+ TEST_DECLARE (spawn_stdout_to_file)
+ TEST_DECLARE (spawn_stdout_and_stderr_to_file)
+ TEST_DECLARE (spawn_stdout_and_stderr_to_file2)
+@@ -351,7 +353,9 @@ TEST_DECLARE (win32_signum_number)
+ TEST_DECLARE (emfile)
+ TEST_DECLARE (close_fd)
+ TEST_DECLARE (spawn_fs_open)
++#if 0
+ TEST_DECLARE (spawn_setuid_setgid)
++#endif
+ TEST_DECLARE (we_get_signal)
+ TEST_DECLARE (we_get_signals)
+ TEST_DECLARE (signal_multiple_loops)
+@@ -669,8 +673,10 @@ TASK_LIST_START
+ TEST_ENTRY (spawn_and_kill_with_std)
+ TEST_ENTRY (spawn_and_ping)
+ TEST_ENTRY (spawn_preserve_env)
++#if 0
+ TEST_ENTRY (spawn_setuid_fails)
+ TEST_ENTRY (spawn_setgid_fails)
++#endif
+ TEST_ENTRY (spawn_stdout_to_file)
+ TEST_ENTRY (spawn_stdout_and_stderr_to_file)
+ TEST_ENTRY (spawn_stdout_and_stderr_to_file2)
+@@ -701,7 +707,9 @@ TASK_LIST_START
+ TEST_ENTRY (emfile)
+ TEST_ENTRY (close_fd)
+ TEST_ENTRY (spawn_fs_open)
++#if 0
+ TEST_ENTRY (spawn_setuid_setgid)
++#endif
+ TEST_ENTRY (we_get_signal)
+ TEST_ENTRY (we_get_signals)
+ TEST_ENTRY (signal_multiple_loops)