aboutsummaryrefslogtreecommitdiffstats
path: root/main/libuv
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-03-07 15:14:09 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-08 10:24:24 +0000
commitaafe70811d90152fa731ca379a7473de8f33c637 (patch)
treec4ee5b508d0db9f492dcf6045f196b951cd1df33 /main/libuv
parent417412671f3c99dc6e9e0fd411d97345bc3ff20c (diff)
downloadaports-aafe70811d90152fa731ca379a7473de8f33c637.tar.bz2
aports-aafe70811d90152fa731ca379a7473de8f33c637.tar.xz
main/libuv: Enable check and debug package
Diffstat (limited to 'main/libuv')
-rw-r--r--main/libuv/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/libuv/APKBUILD b/main/libuv/APKBUILD
index 844e334823..a99fb66324 100644
--- a/main/libuv/APKBUILD
+++ b/main/libuv/APKBUILD
@@ -3,13 +3,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libuv
pkgver=1.11.0
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform asychronous I/O"
url="http://libuv.org"
arch="all"
license="MIT BSD ISC"
makedepends="automake autoconf libtool linux-headers"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-dbg"
source="http://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -40,4 +40,9 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+check() {
+ cd "$builddir"
+ make check || return 1
+}
+
sha512sums="5b56e4c337093c6ddc12f8353b011fba9e57fd84565e279bfc13a7d16d3b6dc01f02fee52a32f38ef630a0f5200fc63f3cc04137af21942422c3dcf535212f02 libuv-v1.11.0.tar.gz"