aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvdpau
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 00:25:34 -0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-08-29 09:08:20 +0000
commit736b232fc8d16cb86873fca2a2dab85662f053b2 (patch)
tree68f2da277485ed5ebd34ed87d39779d8e10aedf2 /main/libvdpau
parentb863787eac1f8acecaa3fb9e599d81eea79d8065 (diff)
downloadaports-736b232fc8d16cb86873fca2a2dab85662f053b2.tar.bz2
aports-736b232fc8d16cb86873fca2a2dab85662f053b2.tar.xz
main/libvdpau: upgrade to 1.3
Diffstat (limited to 'main/libvdpau')
-rw-r--r--main/libvdpau/APKBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
index 40d0c6332a..e91d040466 100644
--- a/main/libvdpau/APKBUILD
+++ b/main/libvdpau/APKBUILD
@@ -1,39 +1,37 @@
# Contributor: Carlo Landmeter
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libvdpau
-pkgver=1.2
+pkgver=1.3
pkgrel=0
pkgdesc="Hardware-accelerated video playback library"
-url="https://cgit.freedesktop.org/~aplattner/libvdpau"
+url="https://gitlab.freedesktop.org/vdpau/libvdpau"
arch="all"
-license="custom"
-makedepends="xorgproto libx11-dev libxext-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://gitlab.freedesktop.org/vdpau/libvdpau/uploads/14b620084c027d546fa0b3f083b800c6/libvdpau-${pkgver}.tar.bz2"
+license="MIT"
+makedepends="xorgproto libx11-dev libxext-dev meson"
+subpackages="$pkgname-dev"
+source="https://gitlab.freedesktop.org/vdpau/libvdpau/-/archive/$pkgver/libvdpau-$pkgver.tar.gz"
build() {
cd "$builddir"
- LIBS="-lX11" \
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
- make
+ --localstatedir=/var \
+ --buildtype=release \
+ -Ddri2=true \
+ . output
+ ninja -C output
}
check() {
cd "$builddir"
- make check
+ ninja -C output test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
- install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="86aa3f2a39cb73a597bf417da2eeef73ff01160ed9f54dff3725785ff5a289f47040496de44e2f5292d59657d4746e369b3fa307c4f83a32f7cc28e4cd8bce6f libvdpau-1.2.tar.bz2"
+sha512sums="7df0079c41ff7fd9f80e4500353c8154f57eb456f703aee4a9ff4d810185ef453fcf1b3925d13337b6765dbc86335e9700ef91f88b073c5bb5c8f9181447dea1 libvdpau-1.3.tar.gz"