aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcb
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-05-29 18:58:24 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-06-01 14:54:41 +0000
commitb135ff5ed4a8ca3b6fc03ea1222c1bc4582dac65 (patch)
tree2ef3a38fe47ec05490aa720bf28cc9b055906e7c /main/libxcb
parent27d745b1aa167b0324c994f299414007a0bc984d (diff)
downloadaports-b135ff5ed4a8ca3b6fc03ea1222c1bc4582dac65.tar.bz2
aports-b135ff5ed4a8ca3b6fc03ea1222c1bc4582dac65.tar.xz
main/libxcb: upgrade to 1.13
Remove python3.patch since changes have been upstreamed.
Diffstat (limited to 'main/libxcb')
-rw-r--r--main/libxcb/APKBUILD10
-rw-r--r--main/libxcb/python3.patch55
2 files changed, 4 insertions, 61 deletions
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index c0626d6977..31009de0c1 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcb
-pkgver=1.12
-pkgrel=1
+pkgver=1.13
+pkgrel=0
pkgdesc="X11 client-side library"
url="https://xcb.freedesktop.org/"
arch="all"
@@ -11,8 +11,7 @@ subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
-source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
- python3.patch"
+source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
@@ -39,5 +38,4 @@ check() {
make check
}
-sha512sums="4ce3e3f62b7e1c3a9e61c149c720ef2a4a760539ea615d7d52ae39e7f5a08456dc87d7a1ac5d85ca15dcc468a9a02d56fb8f8f6361c959af9b8780f011995896 libxcb-1.12.tar.bz2
-ad3b9d9b16b42756a72e583b7d42bd670ef581b614cf185de667badb6121524b84f2738933d2ea1e5da3d135b3a5f2296eb62206463bedc9e4d3f8343f476f85 python3.patch"
+sha512sums="d99bbe386a65f60fcc0cc2935e4a365bc0577b5e90433e18778a665a5aee8ebc8e9e8cb0aedac0ac4a276147c0507e759a716874ea4f80792b2fc18eefbc128c libxcb-1.13.tar.bz2"
diff --git a/main/libxcb/python3.patch b/main/libxcb/python3.patch
deleted file mode 100644
index bbac9a96fc..0000000000
--- a/main/libxcb/python3.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 8740a288ca468433141341347aa115b9544891d3 Mon Sep 17 00:00:00 2001
-From: Thomas Klausner <wiz@NetBSD.org>
-Date: Thu, 19 May 2016 17:31:18 +0200
-Subject: Fix inconsistent use of tabs vs. space.
-
-Needed for at least python-3.5.x.
-
-Signed-off-by: Thomas Klausner <wiz@NetBSD.org>
-Signed-off-by: Uli Schlachter <psychon@znc.in>
-
-diff --git a/src/c_client.py b/src/c_client.py
-index 57de3fb..043338d 100644
---- a/src/c_client.py
-+++ b/src/c_client.py
-@@ -1364,7 +1364,7 @@ def _c_serialize(context, self):
- _c(' unsigned int xcb_align_to = 0;')
- if self.is_switch:
- _c(' unsigned int xcb_padding_offset = %d;',
-- self.get_align_offset() )
-+ self.get_align_offset() )
- prefix = [('_aux', '->', self)]
- aux_ptr = 'xcb_out'
-
-@@ -1390,7 +1390,7 @@ def _c_serialize(context, self):
- _c(' unsigned int xcb_align_to = 0;')
- if self.is_switch:
- _c(' unsigned int xcb_padding_offset = %d;',
-- self.get_align_offset() )
-+ self.get_align_offset() )
-
- elif 'sizeof' == context:
- param_names = [p[2] for p in params]
-@@ -1930,14 +1930,14 @@ def _c_accessors_list(self, field):
- # from the request size and divide that by the member size
- return '(((R->length * 4) - sizeof('+ self.c_type + '))/'+'sizeof('+field.type.member.c_wiretype+'))'
- else:
-- # use the accessor to get the start of the list, then
-- # compute the length of it by subtracting it from
-+ # use the accessor to get the start of the list, then
-+ # compute the length of it by subtracting it from
- # the adress of the first byte after the end of the
- # request
-- after_end_of_request = '(((char*)R) + R->length * 4)'
-- start_of_list = '%s(R)' % (field.c_accessor_name)
-+ after_end_of_request = '(((char*)R) + R->length * 4)'
-+ start_of_list = '%s(R)' % (field.c_accessor_name)
- bytesize_of_list = '%s - (char*)(%s)' % (after_end_of_request, start_of_list)
-- return '(%s) / sizeof(%s)' % (bytesize_of_list, field.type.member.c_wiretype)
-+ return '(%s) / sizeof(%s)' % (bytesize_of_list, field.type.member.c_wiretype)
- else:
- raise Exception(
- "lengthless lists with varsized members are not supported. Fieldname '%s'"
---
-cgit v0.10.2
-