aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcb
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-05-27 20:36:30 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-05-27 20:36:30 +0000
commitbc89232fbdea90b48a67cd2c0562092b102a56b2 (patch)
tree11e342cd9522dc0ea6a183fd0661bf25b6bd86e4 /main/libxcb
parentc8cf3118ca7a45dbb5fe677bb31dbf49c80344cf (diff)
downloadaports-bc89232fbdea90b48a67cd2c0562092b102a56b2.tar.bz2
aports-bc89232fbdea90b48a67cd2c0562092b102a56b2.tar.xz
main/libxcb: modernize apkbuild, switch to python3, enable tests
Diffstat (limited to 'main/libxcb')
-rw-r--r--main/libxcb/APKBUILD36
-rw-r--r--main/libxcb/python3.patch55
2 files changed, 71 insertions, 20 deletions
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index 572cc56050..b45dcfe6a0 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcb
pkgver=1.12
-pkgrel=0
+pkgrel=1
pkgdesc="X11 client-side library"
url="http://xcb.freedesktop.org/"
arch="all"
@@ -9,22 +9,14 @@ license="custom"
depends=
subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
-makedepends="$depends_dev libxslt python2 libpthread-stubs libxdmcp-dev"
+makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
- "
+ python3.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,15 +24,19 @@ build() {
--enable-xkb \
--enable-xinput \
--disable-xprint \
- || return 1
- make || return 1
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="28e552bd78bc1050b6b26ca1db0e5bb6 libxcb-1.12.tar.bz2"
-sha256sums="4adfb1b7c67e99bc9c2ccb110b2f175686576d2f792c8a71b9c8b19014057b5b libxcb-1.12.tar.bz2"
-sha512sums="4ce3e3f62b7e1c3a9e61c149c720ef2a4a760539ea615d7d52ae39e7f5a08456dc87d7a1ac5d85ca15dcc468a9a02d56fb8f8f6361c959af9b8780f011995896 libxcb-1.12.tar.bz2"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="4ce3e3f62b7e1c3a9e61c149c720ef2a4a760539ea615d7d52ae39e7f5a08456dc87d7a1ac5d85ca15dcc468a9a02d56fb8f8f6361c959af9b8780f011995896 libxcb-1.12.tar.bz2
+ad3b9d9b16b42756a72e583b7d42bd670ef581b614cf185de667badb6121524b84f2738933d2ea1e5da3d135b3a5f2296eb62206463bedc9e4d3f8343f476f85 python3.patch"
diff --git a/main/libxcb/python3.patch b/main/libxcb/python3.patch
new file mode 100644
index 0000000000..bbac9a96fc
--- /dev/null
+++ b/main/libxcb/python3.patch
@@ -0,0 +1,55 @@
+From 8740a288ca468433141341347aa115b9544891d3 Mon Sep 17 00:00:00 2001
+From: Thomas Klausner <wiz@NetBSD.org>
+Date: Thu, 19 May 2016 17:31:18 +0200
+Subject: Fix inconsistent use of tabs vs. space.
+
+Needed for at least python-3.5.x.
+
+Signed-off-by: Thomas Klausner <wiz@NetBSD.org>
+Signed-off-by: Uli Schlachter <psychon@znc.in>
+
+diff --git a/src/c_client.py b/src/c_client.py
+index 57de3fb..043338d 100644
+--- a/src/c_client.py
++++ b/src/c_client.py
+@@ -1364,7 +1364,7 @@ def _c_serialize(context, self):
+ _c(' unsigned int xcb_align_to = 0;')
+ if self.is_switch:
+ _c(' unsigned int xcb_padding_offset = %d;',
+- self.get_align_offset() )
++ self.get_align_offset() )
+ prefix = [('_aux', '->', self)]
+ aux_ptr = 'xcb_out'
+
+@@ -1390,7 +1390,7 @@ def _c_serialize(context, self):
+ _c(' unsigned int xcb_align_to = 0;')
+ if self.is_switch:
+ _c(' unsigned int xcb_padding_offset = %d;',
+- self.get_align_offset() )
++ self.get_align_offset() )
+
+ elif 'sizeof' == context:
+ param_names = [p[2] for p in params]
+@@ -1930,14 +1930,14 @@ def _c_accessors_list(self, field):
+ # from the request size and divide that by the member size
+ return '(((R->length * 4) - sizeof('+ self.c_type + '))/'+'sizeof('+field.type.member.c_wiretype+'))'
+ else:
+- # use the accessor to get the start of the list, then
+- # compute the length of it by subtracting it from
++ # use the accessor to get the start of the list, then
++ # compute the length of it by subtracting it from
+ # the adress of the first byte after the end of the
+ # request
+- after_end_of_request = '(((char*)R) + R->length * 4)'
+- start_of_list = '%s(R)' % (field.c_accessor_name)
++ after_end_of_request = '(((char*)R) + R->length * 4)'
++ start_of_list = '%s(R)' % (field.c_accessor_name)
+ bytesize_of_list = '%s - (char*)(%s)' % (after_end_of_request, start_of_list)
+- return '(%s) / sizeof(%s)' % (bytesize_of_list, field.type.member.c_wiretype)
++ return '(%s) / sizeof(%s)' % (bytesize_of_list, field.type.member.c_wiretype)
+ else:
+ raise Exception(
+ "lengthless lists with varsized members are not supported. Fieldname '%s'"
+--
+cgit v0.10.2
+