aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxkbcommon
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-02 16:55:37 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:53:39 +0000
commitc6c0100762b3f8e10b37fa9492953384799c8d88 (patch)
treed1dcee154dc27ca2c3d9557cbf140b28258ad7b0 /main/libxkbcommon
parent1b59d4ef6c5afea29c276da23f94086100ba4783 (diff)
downloadaports-c6c0100762b3f8e10b37fa9492953384799c8d88.tar.bz2
aports-c6c0100762b3f8e10b37fa9492953384799c8d88.tar.xz
main/libxkbcommon: add test suite
Diffstat (limited to 'main/libxkbcommon')
-rw-r--r--main/libxkbcommon/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/main/libxkbcommon/APKBUILD b/main/libxkbcommon/APKBUILD
index 6ef35f8a00..658f2a6ca5 100644
--- a/main/libxkbcommon/APKBUILD
+++ b/main/libxkbcommon/APKBUILD
@@ -2,12 +2,13 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libxkbcommon
pkgver=0.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="a keyboard handling library"
url="http://www.xkbcommon.org/"
arch="all"
license="MIT"
-makedepends="$depends_dev bison flex libxcb-dev"
+makedepends="bison flex libxcb-dev xproto kbproto util-macros"
+checkdepends="bash"
subpackages="$pkgname-dev"
source="http://xkbcommon.org/download/libxkbcommon-$pkgver.tar.xz"
@@ -26,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install