aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxshmfence/APKBUILD
diff options
context:
space:
mode:
authorBobby Bingham <koorogi@koorogi.info>2017-08-05 17:06:37 -0500
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:15:12 +0000
commit97f832b1bbd37633bc95dc19f05704221c7de919 (patch)
treea46c76ce19bee45de58e1d9ed230cf920c3d5436 /main/libxshmfence/APKBUILD
parentae44d71ab88f64f360a35f4eb36dcdb08099fb04 (diff)
downloadaports-97f832b1bbd37633bc95dc19f05704221c7de919.tar.bz2
aports-97f832b1bbd37633bc95dc19f05704221c7de919.tar.xz
main/libxshmfence: use futex instead of pthreads
This library uses a synchronization primitive in shared memory. The pthreads types are not the same size between 32- and 64-bit, which means that a 32-bit binary using mesa cannot be used with a 64-bit X server. The futex backend does not have this problem.
Diffstat (limited to 'main/libxshmfence/APKBUILD')
-rw-r--r--main/libxshmfence/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/libxshmfence/APKBUILD b/main/libxshmfence/APKBUILD
index 01d2c9a84d..c623fc3fd6 100644
--- a/main/libxshmfence/APKBUILD
+++ b/main/libxshmfence/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer:
pkgname=libxshmfence
pkgver=1.2
-pkgrel=0
+pkgrel=1
pkgdesc="X11 shared memory fences"
url="http://www.x.org/"
arch="all"
license="MIT"
depends=""
-depends_dev="xproto"
+depends_dev="xproto linux-headers"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
@@ -32,6 +32,7 @@ build() {
--host=$CHOST \
--prefix=/usr \
--disable-static \
+ --enable-futex \
|| return 1
make || return 1
}