aboutsummaryrefslogtreecommitdiffstats
path: root/main/lighttpd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-05 11:59:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:15 +0000
commit94be998e6d31bb49994dfeecce147ec47efef6b5 (patch)
tree821c6a77a61fdc006acd3fa96445a19862307372 /main/lighttpd
parentf8ede2da2c79cffcc07fbe09965d1d56af083953 (diff)
downloadaports-94be998e6d31bb49994dfeecce147ec47efef6b5.tar.bz2
aports-94be998e6d31bb49994dfeecce147ec47efef6b5.tar.xz
main/lighttpd: upgrade to 1.4.40 and remove streaming
Diffstat (limited to 'main/lighttpd')
-rw-r--r--main/lighttpd/APKBUILD50
-rw-r--r--main/lighttpd/config_insert_values_global.patch11
2 files changed, 9 insertions, 52 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index a440a3ddd6..1709760de9 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
-pkgver=1.4.39
-_streamver=2.2.0
-pkgrel=4
+pkgver=1.4.40
+pkgrel=0
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
@@ -12,11 +11,9 @@ install="$pkgname.pre-install $pkgname.pre-upgrade"
depends=
pkgusers="lighttpd"
pkggroups="lighttpd"
-makedepends="flex pcre-dev libressl-dev zlib-dev bzip2-dev lua-dev
+makedepends="flex pcre-dev libressl-dev zlib-dev bzip2-dev lua5.3-dev
automake autoconf openldap-dev libxml2-dev sqlite-dev libev-dev"
source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.xz
- http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
- config_insert_values_global.patch
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
@@ -26,31 +23,17 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mod_fastcgi.conf
mod_fastcgi_fpm.conf
"
-subpackages="$pkgname-doc $pkgname-dbg $pkgname-mod_auth $pkgname-mod_h264_streaming
+subpackages="$pkgname-doc $pkgname-dbg $pkgname-mod_auth
$pkgname-mod_webdav"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- # copy over the mod-h264-streaming mod
- # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
- cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
- cp "$srcdir"/lighttpd-1.4.18/src/mod_h264_streaming.c src/
-
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
-
- cat >> src/Makefile.am <<__EOF__
-
-lib_LTLIBRARIES += mod_h264_streaming.la
-mod_h264_streaming_la_SOURCES = mod_h264_streaming.c moov.c
-mod_h264_streaming_la_LDFLAGS = -module -export-dynamic -avoid-version -no-undefined
-mod_h264_streaming_la_LIBADD = \$(common_libadd)
-__EOF__
- aclocal -I m4 && autoconf && automake --add-missing
}
build() {
@@ -70,7 +53,6 @@ build() {
--with-webdav-props \
--with-webdav-locks \
--without-gdbm \
- --without-memcache \
--with-bzip2 \
--with-ldap \
--with-openssl \
@@ -87,7 +69,7 @@ package() {
# create dirs
install -d -m755 -o lighttpd -g lighttpd \
- "$pkgdir"/var/log/lighttpd/ || return 1
+ "$pkgdir"/var/log/lighttpd/ || return 1
install -d -m755 \
"$pkgdir"/etc/lighttpd/ \
"$pkgdir"/var/www/localhost/htdocs || return 1
@@ -97,7 +79,7 @@ package() {
install -D -m644 "$srcdir"/lighttpd.confd "$pkgdir"/etc/conf.d/lighttpd
install -D -m644 "$srcdir"/lighttpd.logrotate \
"$pkgdir"/etc/logrotate.d/lighttpd
-
+
# config files
for i in lighttpd.conf mime-types.conf mod_cgi.conf mod_fastcgi.conf mod_fastcgi_fpm.conf; do
install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
@@ -113,14 +95,6 @@ _mv_mod() {
done
}
-mod_h264_streaming() {
- pkgdesc="H264 Streaming Module for lighttpd"
- url="http://h264.code-shop.com/trac"
- license="CCPL-nc-sa-3.0"
- replaces="lighttpd-h264_streaming"
- _mv_mod mod_h264_streaming
-}
-
mod_auth() {
pkgdesc="Authentication module for lighttpd"
_mv_mod mod_auth
@@ -132,9 +106,7 @@ mod_webdav() {
}
-md5sums="63c7563be1c7a7a9819a51f07f1af8b2 lighttpd-1.4.39.tar.xz
-ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
-6d983018d6c3119e06044b232587ec4b config_insert_values_global.patch
+md5sums="89e0da2b6b8a2c4592d549ff10094068 lighttpd-1.4.40.tar.xz
454fcefb873a08b7556d77ade17387ef lighttpd.initd
61a416bbbc504843142bdfe8077964e0 lighttpd.confd
6846f00fff531bb3883904810264decf lighttpd.logrotate
@@ -143,9 +115,7 @@ f3353baa4577703ec3a30c03482df986 mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
32bda92c408640c4c72123cbf1175172 mod_fastcgi.conf
aee5947a1abf380b0685a534ca384b42 mod_fastcgi_fpm.conf"
-sha256sums="7eb9a1853c3d6dd5851682b0733a729ba4158d6bdff80974d5ef5f1f6887365b lighttpd-1.4.39.tar.xz
-732cf98d823f2c7ddc96a3130a3c88d588b02ed20a0e7f8c9be25a265fbea2d6 lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
-23a341837199f043fc62a64478fa4a3f1064683db3f0ffd2ee184ce0f030daba config_insert_values_global.patch
+sha256sums="80450dfcf7604d6c516a00a0ce750937074ef844bbdee3b3f23384187b9d4f8d lighttpd-1.4.40.tar.xz
4ce8a56c47bffb6b7b03e88cfb7a2ceb1d396e8bc7502d0de66d81e732c861af lighttpd.initd
80e03abc267b163f332718545b5ec3a21adef74ecd60098c4e4f7d7c88c21a76 lighttpd.confd
0fff2602a2809662f7fcfe78be52bebc71338f545b26fd41e5c1d74e20486104 lighttpd.logrotate
@@ -154,9 +124,7 @@ sha256sums="7eb9a1853c3d6dd5851682b0733a729ba4158d6bdff80974d5ef5f1f6887365b li
322656b4cfd22ca9f1f8ab160e0b932f1646622422fd49c6fc82ab416223eecf mod_cgi.conf
799e3b61cae677e71f95fa0483bd4cd35d9f28adf79ce680c687d2b476eb677d mod_fastcgi.conf
e7eb047360e09d1a2b693f08d4a912b99954090c5bdea706f46a33554e867043 mod_fastcgi_fpm.conf"
-sha512sums="69bf56afe2bec381566defdc20961554e405e5e7f77b0067e1a29a04e65167b9283cf08655b8dae1c2b6fdddde31245253b5506a532a83f363dce066811b61b3 lighttpd-1.4.39.tar.xz
-12e1b7c8146cccfa78678ce56cd2f704423559b23b90996dff00602634f110512146386086ac234293a3c28900a06c2bec1c97e680e7eed5173372f88177b351 lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
-3d4c598f612dedccb64822f345a8748c96bf5c103d4d3bd153d0046669748475ecbf92d3d576d06f88d055a054345847cdb39826330db54452c9d4d71b6ebb98 config_insert_values_global.patch
+sha512sums="7bcbfb48674815523ee43a6e7b0bbe805fcad03a168f7f1f7b91022705c3aa16d7e842d638672c197d5e10dc94e07db25e7699195d9ac02ef92c51b815f5d1eb lighttpd-1.4.40.tar.xz
f2f3c5c7731550237fd75a8de66275f427eaf897cffff7ac7ef44178328ad8fad6c4ec6654759bfc665cbaf7991ddcdf0aaa916831c8b6aa440192d57b242038 lighttpd.initd
9d2ab5deb7353ebf290e90936b511941df440859c78589d0bcf130ef69a5e9c79e4d318548b6b118df002083c46f7476230a28954b7a10a9dbd05040e02b1291 lighttpd.confd
0536b4f21d2e8659f7831b45998c13d9f6051ae7ecde13be01f372f837d255bfc4e211de48a7686cc743d53aa9c08ab3f10ec19788896dcf8356b90053ca7a16 lighttpd.logrotate
diff --git a/main/lighttpd/config_insert_values_global.patch b/main/lighttpd/config_insert_values_global.patch
deleted file mode 100644
index af9fc7778a..0000000000
--- a/main/lighttpd/config_insert_values_global.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- old/src/mod_h264_streaming.c
-+++ new/src/mod_h264_streaming.c
-@@ -168,7 +168,7 @@
-
- p->config_storage[i] = s;
-
-- if (0 != config_insert_values_global(srv, ((data_config *)srv->config_context->data[i])->value, cv)) {
-+ if (0 != config_insert_values_global(srv, ((data_config *)srv->config_context->data[i])->value, cv, i == 0 ? T_CONFIG_SCOPE_SERVER : T_CONFIG_SCOPE_CONNECTION)) {
- return HANDLER_ERROR;
- }
- }